Opened 5 years ago

Closed 5 years ago

#51206 closed defect (fixed)

xine-lib: build fails with ffmpeg-3.0+

Reported by: dbevans (David B. Evans) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: xine-lib

Description

As noted in #50694, the current version of xine-lib fails to build with ffmpeg 3.0+ due to the use of deprecated API removed that has been removed in 3.0.

Attached is a patch that addresses this issue, allowing xine-lib to build with both ffmpeg 2.8 and 3.0+. I suggest committing these changes now allowing the port to be updated to ffmpeg 3.0 with a simple revbump when that port is committed.

Attachments (1)

patch-xine-lib-ffmpeg-3.0.diff (2.6 KB) - added by dbevans (David B. Evans) 5 years ago.
Proposed patch allowing build with either ffmpeg 2.8 or 3.0+

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by dbevans (David B. Evans)

Proposed patch allowing build with either ffmpeg 2.8 or 3.0+

comment:1 Changed 5 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Committed in r148142.

Note: See TracTickets for help on using tickets.