Opened 3 years ago

Closed 2 years ago

#51288 closed defect (fixed)

py27-astropy @1.0.4_0 Building Error: command execution failed

Reported by: alison.mansheim@… Owned by: robitaille@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: py-astropy

Description

Hi! I am using Xcode 3.2.6 (1761) on OSX 10.6.8. I had a problem when updating my ports and went down a rabbit hole indicating the c compiler was the problem, so I switched compilers, and the immediate problem went away but now I can't get through port upgrade outdated without an error. The compiler may not be the problem here, but in case it is, I wanted to give that background. First I have pasted the error from the terminal after typing sudo port upgrade outdated. Below that I pasted the end of the main.log. I attached the entire main.log. Thank you for your help!!!:

--->  Building py27-astropy
Error: org.macports.build for port py27-astropy returned: command execution failed

From main.log around where error messages start:

:info:build running pre_hook from astropy._erfa.setup_package for build_ext comm
and
:info:build running pre_hook from astropy.modeling.setup_package for build_ext c
ommand
:info:build WARNING: The autogenerated wrappers in astropy.modeling._projections
 seem to be older than the source templates used to create them. Because this is
 a release version we will use them anyway, but this might be a sign of some sor
t of version mismatch or other tampering. Or it might just mean you moved some f
iles around or otherwise accidentally changed timestamps.
:info:build building 'astropy.modeling._projections' extension
:info:build /usr/bin/gcc-4.2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -
arch x86_64 -DECHO -DWCSTRIG_MACRO -DASTROPY_WCS_BUILD -D_GNU_SOURCE -DNDEBUG -U
DEBUG -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.
7/site-packages/numpy/core/include -I/opt/local/include/wcslib -Iastropy/modeling/src -I/opt/local/Library/Frameworks/Python.framework/Versions/2.7/include/pyth
on2.7 -c astropy/modeling/src/projections.c -o build/temp.macosx-10.6-x86_64-2.7
/astropy/modeling/src/projections.o -Wno-strict-prototypes -Wno-unused-function -Wno-unused-value -Wno-uninitialized -Wno-unused-but-set-variable
:info:build cc1: error: unrecognized command line option "-Wno-unused-function -Wno-unused-value -Wno-uninitialized -Wno-unused-but-set-variable
:info:build cc1: error: unrecognized command line option "-Wno-unused-but-set-variable"
:info:build error: command '/usr/bin/gcc-4.2' failed with exit status 1
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-astropy/py27-astropy/work/astropy-1.1.1" && /opt/local/Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7 setup.py --no-user-cfg --offline --no-git build --use-system-cfitsio --use-system-expat --use-system-wcslib --use-system-erfa 
:info:build Exit code: 1
:error:build org.macports.build for port py27-astropy returned: command execution failed
:debug:build Error code: CHILDSTATUS 34565 1
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for py27-astropy: org.macports.install org.macports.build org.macports.destroot
:notice:build Please see the log file for port py27-astropy for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.morg_release_tarballs_ports_python_py-astropy/py27-astropy/main.log

Attachments (3)

main.log (6.7 KB) - added by alison.mansheim@… 3 years ago.
main.log
main.2.log (112.7 KB) - added by alison.mansheim@… 3 years ago.
main.3.log (162.8 KB) - added by alison.mansheim@… 3 years ago.
Clean build of py27-astropy error log

Download all attachments as: .zip

Change History (12)

Changed 3 years ago by alison.mansheim@…

Attachment: main.log added

main.log

comment:1 in reply to:  description Changed 3 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to robitaille@…

Replying to alison.mansheim@…:

I had a problem when updating my ports and went down a rabbit hole indicating the c compiler was the problem,

What error message did you receive, specifically?

so I switched compilers,

How did you do this? Using sudo port select gcc ... or something else?

and the immediate problem went away

If any port builds differently depending on what or whether or not you sudo port selected, that's a bug in that port that needs to be fixed. Ports should always build using the same MacPorts-determined compiler, though that can vary based on Xcode version and OS X version.

but now I can't get through port upgrade outdated without an error. The compiler may not be the problem here, but in case it is, I wanted to give that background. First I have pasted the error from the terminal after typing sudo port upgrade outdated. Below that I pasted the end of the main.log. I attached the entire main.log. Thank you for your help!!!:

The log is not from a clean build attempt. Please sudo port clean py27-astropy, then try again.

Changed 3 years ago by alison.mansheim@…

Attachment: main.2.log added

comment:2 Changed 3 years ago by alison.mansheim@…

Hi! Thank you for your reply. I had already tried sudo port clean py27-astropy before creating this ticket. The instructions said to "try again", which I took to mean run sudo port upgrade outdated again which is why attached the error from that, which was the original error. I am now attaching the main.log from the sudo port clean py27-astropy. Please let me know if I am still misunderstanding the instructions.

I do not recall the exact error from the compiler issue because that issue was resolved (sorry :s). I *think* I got the error while macports was upgrading llvm, and I do recall that it asked me to choose a new compiler from a list (sudo port select gcc ...). After I did this that snag was fixed, but then a few weeks later I got the current error from this ticket.

Thank you for your help!

Last edited 3 years ago by alison.mansheim@… (previous) (diff)

Changed 3 years ago by alison.mansheim@…

Attachment: main.3.log added

Clean build of py27-astropy error log

comment:3 Changed 3 years ago by alison.mansheim@…

Hi! No one replied so I am sending another message before opening a new ticket. For good measure I just I ran a clean build and attached the main.log for py27-astropy. Thank you for your help I would absolutely love to get this working!

comment:4 Changed 2 years ago by mf2k (Frank Schima)

Port: py-astropy added

Please do not do that. Opening a new ticket will do nothing to get this going and will be immediately closed as a duplicate of this one. You should try asking for help on the Macports Users mailing list instead.

comment:5 Changed 2 years ago by alison.mansheim@…

I am confused...after 7 weeks and no one has responded or closed the ticket. Is that the unofficial way of saying no one will ever respond? I do not know how to interpret the .log file so any guidance is appreciated, as it sounds like the answer lies in there. Thank you!

comment:6 Changed 2 years ago by robitaille@…

It doesn't mean that no one will ever respond - but we are all volunteers and there are a lot of issues to look in to, so we are stretched thin :)

I've updated the version of astropy in MacPorts to 1.1.2 in case it helps, but I think that we will need to wait for 1.2 to be available (within the next few days) since I think the issue will definitely be fixed there.

If you want to try 1.1.2, wait an hour after this message, then run selfupdate then try installing astropy again.

comment:7 Changed 2 years ago by robitaille@…

Astropy 1.2 is now out and available in MacPorts. Can you try running sudo port selfupdate and then try installing the latest version of Astropy to see if this resolves this issue?

comment:8 Changed 2 years ago by alison.mansheim@…

Hi! This resolves the issue. Thank you!!!! The time and effort you put in as a volunteer facilitates a ton of science :) I am so grateful.

comment:9 Changed 2 years ago by robitaille@…

Resolution: fixed
Status: newclosed

Glad it works now! :)

Note: See TracTickets for help on using tickets.