Opened 4 years ago

Closed 4 years ago

#51294 closed defect (duplicate)

Failed to build doxygen while installing gnuradio

Reported by: red.carpet.guitar@… Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: doxygen

Description (last modified by mf2k (Frank Schima))

Hi using a yosemite on mid 2012 macbook pro. While installing gnuradio saw the following error:

Error: org.macports.build for port doxygen returned: command execution failed
Error: Failed to install doxygen

i tried cleaning the gnuradio port by using following command:

sudo port clean gnuradio

but still see the same problem while installing gnuradio.

I have attached the main.log for further debugging.

Attachments (1)

main.log (16.7 KB) - added by red.carpet.guitar@… 4 years ago.
mai.log

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by red.carpet.guitar@…

Attachment: main.log added

mai.log

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: red.carpet.guitar@… removed
Keywords: gnuradio doxygen removed
Owner: changed from macports-tickets@… to css@…
Port: doxygen added; gnuradio removed

In the future, please use WikiFormatting, fill in the Port field with the port that actually failed to build and Cc the port maintainers (port info --maintainers doxygen), if any.

As reporter, you do not need to Cc yourself.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

The log says:

:info:build IOError: [Errno 24] Too many open files: '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_textproc_doxygen/doxygen/work/doxygen-1.8.10/templates/html/search.js'

There seem to be some situations where MacPorts opens too many files. It seems to be when it has very many dependencies to install. You can avoid this problem by installing ports in smaller batches.

Try:

sudo port clean doxygen
sudo port install doxygen

If that works, then try installing other ports you want. You don't have to go so far as to install each port individually, but gnuradio has over 260 dependencies, which is currently problematic for MacPorts to install all at once.

comment:4 Changed 4 years ago by ken-cunningham-webuse

duplicate of 50986

comment:5 Changed 4 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.