Opened 17 months ago

Closed 17 months ago

Last modified 12 months ago

#51304 closed defect (fixed)

openssl 1.0.2h failing to download

Reported by: robitaille@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: neverpanic (Clemens Lang), ryandesign (Ryan Schmidt), ridethecliche@…
Port: openssl

Description

I am trying to update openssl but am getting the following error:

--->  Computing dependencies for openssl
--->  Fetching distfiles for openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from https://distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://lil.fr.distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://nue.de.distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://www.openssl.org/source
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://osl.no.distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://sea.us.distfiles.macports.org/macports/distfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://jnb.za.distfiles.macports.org/distfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://jog.id.distfiles.macports.org/macports/distfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://cjj.kr.distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://her.gr.distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2h.tar.gz from http://svn.macports.org/repository/macports/distfiles/openssl
Error: org.macports.fetch for port openssl returned: fetch failed
Please see the log file for port openssl for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_openssl/openssl/main.log
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade python27 failed

Attachments (1)

openssl.log (4.9 KB) - added by robitaille@… 17 months ago.
Failure log

Download all attachments as: .zip

Change History (11)

comment:1 Changed 17 months ago by ryandesign (Ryan Schmidt)

  • Cc larryv@… openmaintainer@… removed
  • Owner changed from macports-tickets@… to larryv@…
  • Priority changed from High to Normal

Please attach the main.log file so we can see why it failed to download for you.

Changed 17 months ago by robitaille@…

Failure log

comment:2 Changed 17 months ago by robitaille@…

Done!

comment:4 Changed 17 months ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Resolution set to fixed
  • Status changed from new to closed

I added the file to our distfiles server manually. The problem is that openssl's web site now uses an overly restrictive ssl setup that prevents our distfiles server from mirroring that file automatically; the same issue prevents old versions of OS X from being able to fetch the file from the original server.

comment:5 Changed 12 months ago by ridethecliche@…

Same thing is now happening for openssl-1.0.2i.tar.gz

comment:6 Changed 12 months ago by ridethecliche@…

  • Cc ridethecliche@… added

Cc Me!

comment:7 follow-up: Changed 12 months ago by neverpanic (Clemens Lang)

Which version of OS X are you running? Our 10.6 builder successfully downloaded the file.

I added a couple of other mirrors from the official mirror list in r153049, some of which have the file already.

comment:8 in reply to: ↑ 7 Changed 12 months ago by ridethecliche@…

Hi, I was running 10.5 (PPC)

comment:9 Changed 12 months ago by ryandesign (Ryan Schmidt)

Then that's expected. The version of curl included with 10.5 and earlier don't understand modern SSL certificates. This problem will go away once I've fixed our distfiles mirroring script to mirror distfiles right after an update is committed; right now, we only mirror distfiles twice a week, so there's usually a period of several days after each update during which we haven't mirrored the file yet.

Clemens' fix will also have fixed it for you, for this port, because he added non-https backup sites.

comment:10 Changed 12 months ago by ryandesign (Ryan Schmidt)

And when I said above that our distfiles server can't mirror this file specifically, I was referring to our old distfiles server at macOS forge. Our new distfiles server is not at macOS forge and, once I've installed the new mirroring scripts there, will not have this problem.

Note: See TracTickets for help on using tickets.