Opened 3 years ago

Closed 2 years ago

#51306 closed defect (invalid)

octave-control: configure failure

Reported by: gps@… Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Port: octave-control

Description (last modified by mf2k (Frank Schima))

  • I upgraded to El Capitan.
  • I completely uninstalled all mac ports, and deleted all related macports files from the system.
  • I've been installing selected packages from scratch. octave-control always fails. The problem appears to be with the fetch of the package.
  • Once it fails I try 'port clean octave-control' and always run into the same problem.
  • From the log (attached to the ticket). I see that the fetch is failing.
    :info:archivefetch --->  octave-control-3.0.0_0+gcc5.darwin_15.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
    :msg:archivefetch --->  Attempting to fetch octave-control-3.0.0_0+gcc5.darwin_15.x86_64.tbz2 from https://packages.macports.org/octave-control
    :debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
    :msg:archivefetch --->  Attempting to fetch octave-control-3.0.0_0+gcc5.darwin_15.x86_64.tbz2 from http://sea.us.packages.macports.org/macports/packages/octave-control
    :debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
    :msg:archivefetch --->  Attempting to fetch octave-control-3.0.0_0+gcc5.darwin_15.x86_64.tbz2 from http://lil.fr.packages.macports.org/octave-control
    :debug:archivefetch Fetching archive failed:: The requested URL returned error: 404 Not Found
    

This seems to cause other errors later in the process (see the attached log file).

Attachments (1)

main.log (163.8 KB) - added by gps@… 3 years ago.
log file for installing octave-control

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by gps@…

Attachment: main.log added

log file for installing octave-control

comment:1 Changed 3 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to mschamschula@…

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers octave-control), if any.

comment:2 Changed 3 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 3 years ago by mf2k (Frank Schima)

Summary: octave-control install problem, fetch is failingoctave-control: configure failure

Per your log, it fetches just fine. The problem is in the configure phase.

comment:4 Changed 3 years ago by Schamschula (Marius Schamschula)

Owner: changed from mschamschula@… to mps@…

It looks like your real problem is

2098	:info:configure ld: warning: could not create compact unwind for _dhseqr_: stack subq instruction is too different from dwarf stack size
2099	:info:configure Undefined symbols for architecture x86_64:
2100	:info:configure   "_dgegs_", referenced from:
2101	:info:configure       _sg03ad_ in slicotlibrary.a(SG03AD.o)
2102	:info:configure       _sg03bd_ in slicotlibrary.a(SG03BD.o)
2103	:info:configure   "_dlatzm_", referenced from:
2104	:info:configure       _ab08nx_ in slicotlibrary.a(AB08NX.o)
2105	:info:configure       _ag08by_ in slicotlibrary.a(AG08BY.o)
2106	:info:configure       _sb01by_ in slicotlibrary.a(SB01BY.o)
2107	:info:configure       _sb01fy_ in slicotlibrary.a(SB01FY.o)
2108	:info:configure ld: symbol(s) not found for architecture x86_64
2109	:info:configure clang: error: linker command failed with exit code 1 (use -v to see invocation)
2110	:info:configure make: *** [__control_slicot_functions__.oct] Error 1
2111	:info:configure

Which version of octave did you install? (i.e. octave, octave-devel, octave-devel-rc or octave-devel-release)

comment:5 Changed 3 years ago by Schamschula (Marius Schamschula)

I just installed octave-control against octave-devel-release (octave 4.0.1) under El Capitan and Xcode 7.3.1, w/o any problems.

Try

sudo port clean octave-control

sudo port install octave-control

as there may be remnants of a previous build.

comment:6 in reply to:  5 Changed 3 years ago by gps@…

Replying to mps@…:

I just installed octave-control against octave-devel-release (octave 4.0.1) under El Capitan and Xcode 7.3.1, w/o any problems.

Try

sudo port clean octave-control

sudo port install octave-control

as there may be remnants of a previous build.

Thanks for you're response. This is the first ticket that I've filed and did not fully understand the formatting conventions. I apologize.

I completely uninstalled macports including deleting all macports residuals per the "uninstall" page. I reinstalled macports from scratch and per your suggestion installed octave-devel-release rather than octave. I also did a "port clean octave-control" just in case. I then installed octave-control and ran into the same issue as before.

I do see your notes above about the loader errors. From the log file it appears that octave-control is linking to /opt/local/lib/octave/3.8.2 rather than /opt/local/lib/octave/4.0.1. I'm not sure how to proceed here and would appreciate any suggestions. I'm not able to upload the latest main.log. I get a trac error. Its here: https://www.dropbox.com/s/hzv1jj9ea15ubpm/main.log?dl=0

Thanks for your help.

Last edited 3 years ago by gps@… (previous) (diff)

comment:7 Changed 3 years ago by Schamschula (Marius Schamschula)

If you reinstalled MacPorts, there should not be any octave 3.8.2. What does

port installed octave

show? It should print out

None of the specified ports are installed.

Otherwise, you need to uninstall octave. Also you need to run

sudo port select octave octave-revel-release

Otherwise mkoctfile won't be found.

comment:8 Changed 3 years ago by gps@…

I was able to install octave-control today. The source of the problem was odd. I apparently had an install of xquartz from long ago in the /opt directory. This was confusing the dependencies. I did a total uninstall of macports followed by an uninstall of xquartz, and then a re-install from scratch. Every is working fine now.

I don't see how to close the bug. I consider this bug closed now.

Last edited 3 years ago by gps@… (previous) (diff)

comment:9 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Cc: MarcusCalhoun-Lopez added

comment:10 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: invalid
Status: newclosed

Close at the request of original reporter.

Note: See TracTickets for help on using tickets.