Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#51317 closed defect (fixed)

erlsom @1.2.1_1 Configure error causes build failure

Reported by: afbrand@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: erlsom

Description (last modified by mf2k (Frank Schima))

Erlsom build fails during the configure phase. It reports that that the dependency Erlang is broken, citing a missing path. Nevertheless, the path exists and Erlang executes normally.

The configure.log error line reads:

configure:1920: error: Broken Erlang installation, "/opt/local/lib/erlang" does not exist!

Erlang not only exists, but this path is valid and Erlang runs normally.

Attachments (2)

config.log (4.1 KB) - added by afbrand@… 4 years ago.
Erlsom build configuration log file.
main.log (95.2 KB) - added by afbrand@… 4 years ago.
Erlsom build main log file.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by afbrand@…

Attachment: config.log added

Erlsom build configuration log file.

Changed 4 years ago by afbrand@…

Attachment: main.log added

Erlsom build main log file.

comment:1 Changed 4 years ago by mf2k (Frank Schima)

In the future, please use WikiFormatting.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

I see from your main.log that you're using trace mode. Does the problem persist when not using trace mode?

comment:5 in reply to:  4 Changed 4 years ago by afbrand@…

Replying to ryandesign@…:

I see from your main.log that you're using trace mode. Does the problem persist when not using trace mode?

Yes, the same thing happens. I have trace on, because I believe I saw somewhere in the docs that recommended it. The suggestion was that a traced log was more helpful for those troubleshooting a ticket.

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Ok, I see this too.

The problem is that erlsom's configure script just reads the erl launcher script and takes all the characters after ROOTDIR= as the path to use. The problem is that in erlang 18.3, the line in the erl script reads:

ROOTDIR="/opt/local/lib/erlang"

erlsom's configure script is therefore taking "/opt/local/lib/erlang" -- with the quotation marks -- as the path to use, and that path does not exist. Maybe previous versions of erlang did not enclose the path in quotation marks and therefore didn't expose this problem.

comment:7 Changed 4 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned

comment:8 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

comment:9 Changed 4 years ago by afbrand@…

Installed erlsom without a problem.

Thank you.

Note: See TracTickets for help on using tickets.