Opened 7 years ago

Closed 7 years ago

#51318 closed defect (fixed)

gstreamer1-gst-plugins-good fail to install after upgrade to taglib @1.11

Reported by: basmac Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: Schamschula (Marius Schamschula)
Port: gstreamer1-gst-plugins-good

Description (last modified by mf2k (Frank Schima))

From a clean install of macports on 10.11.4 gimp requires gstreamer1, and this install fails. Attached log file

Attachments (1)

gstreamer1-gst-plugins-good.log (1.8 MB) - added by basmac 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by basmac

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:2 Changed 7 years ago by dbevans (David B. Evans)

Owner: changed from macports-tickets@… to devans@…
Status: newassigned
Summary: gstreamer1-gst-plugins-good fail to installgstreamer1-gst-plugins-good fail to install after upgrade to taglib @1.11

This appears to be the consequence of the recent update of taglib to version 1.11 in r148371. Possible API changes. Existing builds of gstreamer1-gst-plugins-good also break because taglib no longer installs a shared library, only a static one.

Will take a look.

comment:3 Changed 7 years ago by dbevans (David B. Evans)

See related ticket #51319 concerning taglib missing shared library.

comment:4 Changed 7 years ago by dbevans (David B. Evans)

Cc: mps@… added

comment:5 Changed 7 years ago by Schamschula (Marius Schamschula)

Jeremy Huddleston Sequoia re-enabled the .dylib in r148385

comment:6 Changed 7 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed

Confirming that this issue has been resolved. Please update your ports and try again. Thanks for the report.

Note: See TracTickets for help on using tickets.