Opened 5 years ago

Last modified 19 months ago

#51392 new update

play @1.2.7.2: upgrade to 1.3.4

Reported by: nhojpatrick (John Patrick) Owned by: ci42
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: g5pw (Aljaž Srebrnič), mojca (Mojca Miklavec)
Port: play

Description

newer play version 1.3.4

Attachments (2)

devel_play_r148661_Portfile_upgrade-to-1.3.4.diff (844 bytes) - added by nhojpatrick (John Patrick) 5 years ago.
Portfile
play-1.2.7.2_to_1.3.3.diff (2.0 KB) - added by chrisjogorman 5 years ago.
Patch for upgrade to 1.3.3

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by nhojpatrick (John Patrick)

Portfile

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Cc: ciserlohn@… removed
Owner: changed from macports-tickets@… to ciserlohn@…
Port: play added

In the future, please fill in the Port field.

comment:2 Changed 5 years ago by chrisjogorman

Hello Patrick,

I just tried to get play 1.3.4 to build on my machine with no success. It fails trying to build PluginCollection.java

Buildfile: /Users/chrisgorman/src/play-1.3.4/framework/build.xml

clean
   [delete] Deleting: /Users/chrisgorman/src/play-1.3.4/framework/src/play/version

clean-unittest:

version:
     [exec] Result: 128
     [echo] Version 1.3.x-localbuild

compile:
    [mkdir] Created dir: /Users/chrisgorman/src/play-1.3.4/framework/classes
    [javac] /Users/chrisgorman/src/play-1.3.4/framework/build.xml:67: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 294 source files to /Users/chrisgorman/src/play-1.3.4/framework/classes
    [javac] /Users/chrisgorman/src/play-1.3.4/framework/src/play/plugins/PluginCollection.java:476: decorate(play.PlayPlugin.Filter<T>) in play.PlayPlugin.Filter<T> cannot be applied to <T>(play.PlayPlugin.Filter)
    [javac]                 ret = ret.<T> decorate(itr.next().getFilter());
    [javac]                          ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error

BUILD FAILED
/Users/chrisgorman/src/play-1.3.4/framework/build.xml:67: Compile failed; see the compiler error output for details.

Total time: 16 seconds

I can get it to build if I comment the offending line out, but I don't think that would be too good. My java is not good enough to debug the syntax error. Not sure what to do I tried 1.3.3 and 1.4.0 versions, both of which build on my machine. My java is javac 1.6.0_65 and I am running os x 10.6.

Changed 5 years ago by chrisjogorman

Attachment: play-1.2.7.2_to_1.3.3.diff added

Patch for upgrade to 1.3.3

comment:3 Changed 5 years ago by chrisjogorman

Hello John,

Sorry for calling you Patrick, I should have looked at your email more closely. I have a patch for you if you want to use play 1.3.3. In order to get 1.3.4 to build, I have to comment out the

ret = ret.<T> decorate(itr.next().getFilter());

in framework/src/play/plugins/PluginCollection.java, which does not make me comfortable about the end state of the executable.

As for the patch to 1.3.3, it may make a broken install. All I did was modify build.xml as ciserlohn did for 1.2.7.2. Any way it is attached to the ticket if you don't get it in your email.

Chris

comment:4 Changed 2 years ago by mojca (Mojca Miklavec)

We would be grateful for any input on https://github.com/macports/macports-ports/pull/2951

comment:5 Changed 2 years ago by mojca (Mojca Miklavec)

Cc: mojca added

comment:6 Changed 19 months ago by nhojpatrick (John Patrick)

i've moved to using maven instead of activator when running play framework projects so use maven wrapper and standard maven dependencies so don't need this patched anymore, also moved to 2.5.x+ so don't need 1.x anymore from my point of view this can be closed unless others need this patched

Note: See TracTickets for help on using tickets.