Opened 7 years ago

Closed 7 years ago

Last modified 15 months ago

#51489 closed enhancement (duplicate)

build progress indicator

Reported by: RJVB (René Bertin) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version:
Keywords: Cc:
Port:

Description

Certain build systems provide a progress indication in their output; this seems to be the default with CMake at least when using the "Unix Makefiles" and Ninja generators.

It'd be nice if the non-verbose build phase showed this progress like progress is shown during the fetch phase. I don't really have any ideas how to implement this at the moment, but there is at least the KDevelop IDE (the KF5 version) which has a filter somewhere that extracts progress information from make (and ninja) output.

Change History (4)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Type: requestenhancement

Note that a "request" ticket type is only for requesting a new port.

comment:2 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #15939.

comment:3 Changed 15 months ago by mascguy (Christopher Nielsen)

Keywords: progressbar added

comment:4 Changed 15 months ago by mascguy (Christopher Nielsen)

Keywords: progressbar removed
Note: See TracTickets for help on using tickets.