Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#51573 closed defect (duplicate)

libpng: fetch failure

Reported by: bradnull@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: libpng

Description

It looks like the port for opencv is failing because it cannot find libpng version 1.6.22 which is not present on and of the distfiles servers.

Attachments (1)

main.log (3.8 KB) - added by bradnull@… 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by bradnull@…

Cc: bradnull@… added

Cc Me!

comment:2 Changed 7 years ago by mf2k (Frank Schima)

Please attach the main.log so we can see what is going on.

Changed 7 years ago by bradnull@…

Attachment: main.log added

comment:3 Changed 7 years ago by bradnull@…

The main.log has our URL omitted per request of IT, but we have a mirror of the macports servers here. I've also looked at http://distfiles.macports.org/libpng/ and the proper version is not there either. Thanks for the speedy reply!

comment:4 Changed 7 years ago by mf2k (Frank Schima)

Cc: bradnull@… removed
Keywords: opencv libpng removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: libpng added; opencv removed

In the future, please fill in the Port field with the port that actually fails to build and Cc that port's maintainers (port info --maintainers libpng), if any. As reporter, you do not need to Cc yourself.

comment:5 Changed 7 years ago by mf2k (Frank Schima)

Summary: opencv failing because libpng dependency not presentlibpng: fetch failure

comment:6 Changed 7 years ago by arboz@…

comment:7 in reply to:  6 Changed 7 years ago by bradnull@…

Thanks for the link, I downloaded and tried to install again, but now I am getting a failure to download gnutls-3.4.13.tar.xz for the same reason, its not on the distfiles server.

comment:8 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

The fact that the log says "Could not resolve host" makes me think this is a duplicate of #50986. Install fewer ports at once. If you're running into this problem when trying to install a single port, install some of its dependencies manually first.

The fact that the distfiles were not mirrored on the MacPorts network of servers is probably because of #50875. The files should appear there within a few days.

comment:9 in reply to:  8 Changed 7 years ago by bradnull@…

The "Could not resolve host" is actually because the machine that was installing the opencv port is not connected to the internet. We have a mirror of Macports locally that we are connecting to which is synchronized with macports.org. The reason that this is still failing to install is because the required ports are not on our server or the distfiles server. I appreciate your link to that ticket because I think some of our problems are actually caused by the same issue. However, I don't think that is the case here.

My question is: Why is a version of opencv on the macports server that depends on files that don't currently reside there?

Note: See TracTickets for help on using tickets.