Opened 5 years ago

Closed 5 years ago

#51738 closed defect (duplicate)

osxfuse @2.8.2 fails to build with Xcode 7.3

Reported by: arm332@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: osxfuse

Description

osxfuse 2.8.2 fails to build with Xcode 7.3 on El Capitan (10.11.5)

Xcode version:

$ xcodebuild -version
Xcode 7.3.1
Build version 7D1014

Log file for osxfuse is attached.

The attached patches fixed the issue for me.

Attachments (2)

main.log (312.2 KB) - added by arm332@… 5 years ago.
Log file
patch-xcode-7.3.diff (1.4 KB) - added by arm332@… 5 years ago.
Patch to "support" Xcode 7.3

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by arm332@…

Attachment: main.log added

Log file

Changed 5 years ago by arm332@…

Attachment: patch-xcode-7.3.diff added

Patch to "support" Xcode 7.3

comment:1 Changed 5 years ago by arm332@…

Cc: arm332@… added

Cc Me!

comment:2 Changed 5 years ago by mf2k (Frank Schima)

Cc: dports@… openmaintainer@… arm332@… removed
Owner: changed from macports-tickets@… to dports@…

Please do not Cc openmaintainer@… because it is not a valid email address. As reporter, you do not need to Cc yourself.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: haspatch added
Resolution: duplicate
Status: newclosed

Thanks for the patch.

This is a duplicate of #50837. I'll fix it there.

Note: See TracTickets for help on using tickets.