Opened 4 years ago

Closed 4 years ago

#52093 closed defect (duplicate)

py27-awscli should depend on py27-docutils

Reported by: rnowling@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: py27-awscli

Description (last modified by larryv (Lawrence Velázquez))

I installed the py27-awscli package. When I tried to use aws-2.7, I got the following error report:

Traceback (most recent call last):
  File "/opt/local/bin/aws-2.7", line 19, in <module>
    import awscli.clidriver
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/awscli/clidriver.py", line 32, in <module>
    from awscli.help import ProviderHelpCommand
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/awscli/help.py", line 19, in <module>
    from docutils.core import publish_string
ImportError: No module named docutils.core

When I installed py27-docutils, the problem went away.

Change History (1)

comment:1 Changed 4 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #49575.

Note: See TracTickets for help on using tickets.