Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#52127 closed defect (fixed)

ld64 @2 recent Portfile changes break sync on Mountain Lion

Reported by: maxkalashnikov@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), mojca (Mojca Miklavec)
Port: ld64

Description

Running a sync breaks for ld64, even on a completely fresh install on 10.8.5 with XCode Version 5.1.1 (5B1008)

--->  Updating the ports tree
Synchronizing local ports tree from rsync://rsync.macports.org/release/tarballs/ports.tar

Willkommen auf dem RSYNC-server auf ftp.fau.de.
Nicht all unsere Mirror sind per rsync verfuegbar.

Welcome to the RSYNC daemon on ftp.fau.de.
Not all of our mirrors are available through rsync.


receiving file list ... done

sent 16 bytes  received 56 bytes  28.80 bytes/sec
total size is 64327680  speedup is 893440.00

Willkommen auf dem RSYNC-server auf ftp.fau.de.
Nicht all unsere Mirror sind per rsync verfuegbar.

Welcome to the RSYNC daemon on ftp.fau.de.
Not all of our mirrors are available through rsync.


receiving file list ... done

sent 16 bytes  received 63 bytes  31.60 bytes/sec
total size is 512  speedup is 6.48
Creating port index in /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports
Warning: failed to open old entry for devel/ld64, making a new one
Adding port devel/ld64
Error: Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Failed to parse file devel/ld64/Portfile with subport 'ld64-97': Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Error: Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Failed to parse file devel/ld64/Portfile with subport 'ld64-127': Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Error: Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Failed to parse file devel/ld64/Portfile with subport 'ld64-136': Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Error: Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Failed to parse file devel/ld64/Portfile with subport 'ld64-236': Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Error: Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Failed to parse file devel/ld64/Portfile with subport 'ld64-latest': Your platform cannot be configured without LTO support in ld64.  Please enable one of the llvmXX variants, and try again.
Adding subport ld64-xcode

Total number of ports parsed:	7 
Ports successfully parsed:	2 
Ports failed:			5 
Up-to-date ports skipped:	21256

Change History (7)

comment:1 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: fixed
Status: newclosed

comment:2 Changed 5 years ago by jmroot (Joshua Root)

That just moves the error to install time; the issue is that no default variant is being set on darwin 12.

comment:3 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yep, r152089.

comment:4 Changed 5 years ago by mojca (Mojca Miklavec)

Jeremy, you should probably make another revbump. I ended up with

ld64-latest @264.3.102_2+llvm34 (active)

installed on Lion because you made the revbump (r152013) before llvm34 variant was removed (r152081).

Sorry, it's not exactly the same issues, but I don't want to open a new ticket just for the sake of a single revbump.

Last edited 5 years ago by mojca (Mojca Miklavec) (previous) (diff)

comment:5 Changed 5 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:6 Changed 5 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Revbump per your request: r152133

comment:7 Changed 5 years ago by mojca (Mojca Miklavec)

Thanks.

Note: See TracTickets for help on using tickets.