Opened 5 years ago

Closed 5 years ago

#52133 closed update (fixed)

demeter @0.9.25 needs to update both upstream version and Perl version

Reported by: joefowler (Joe Fowler) Owned by: Ionic (Mihai Moldovan)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: haspatch, maintainer Cc:
Port: demeter

Description

I need a committer to update using the attached patch.

Port demeter (and sub-port demeter-devel) should switch to the new upstream version 0.9.25.

More urgently, the new Portfile uses Perl 5.24 instead of 5.22, as requested by ticket #52081.

Attachments (1)

demeter.diff (4.6 KB) - added by joefowler (Joe Fowler) 5 years ago.
This patch replaces the earlier one.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by joefowler (Joe Fowler)

Attachment: demeter.diff added

This patch replaces the earlier one.

comment:1 Changed 5 years ago by joefowler (Joe Fowler)

I just heard from the upstream maintainer, with a list of dependencies that are no longer needed. I have changed the demeter.diff patch file to reflect his new requirements.

comment:2 Changed 5 years ago by Ionic (Mihai Moldovan)

Owner: changed from macports-tickets@… to ionic@…
Status: newassigned

comment:3 Changed 5 years ago by Ionic (Mihai Moldovan)

Resolution: fixed
Status: assignedclosed

Split up and committed as r152139 (Perl version switch) and r152140 (verbump.)

Note: See TracTickets for help on using tickets.