Opened 4 years ago

Closed 22 months ago

#52162 closed defect (invalid)

DIgikam Fails to Compile

Reported by: felixboecker@… Owned by: jgosmann (Jan Gosmann)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: cgilles (HumanDynamo)
Port: digikam

Description

Hello! Trying to install digikam but it won't compile. I'm relatively new to OS X and this is my first try at MacPorts so not sure where this is hanging up. Google didn't seem to find anything similar either. This is the end of the log file:

:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_digikam/digikam/work/build'
:info:build [  2%] Built target digikam_automoc
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_digikam/digikam/work/build'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_digikam/digikam/work/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_digikam/digikam/work/build" && /usr/bin/make -j4 -w all VERBOSE=ON 
:info:build Exit code: 2
:error:build org.macports.build for port digikam returned: command execution failed
:debug:build Error code: CHILDSTATUS 19026 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for digikam: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port digikam for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_kde_digikam/digikam/main.log

Hope someone can figure this out. Thanks!

Change History (4)

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: caulier.gilles@… added
Owner: changed from macports-tickets@… to jan@…

In the future, please Cc the port maintainers (port info --maintainers digikam), if any.

comment:2 Changed 4 years ago by felixboecker@…

Sorry about that! Will keep that in mind for the future (although I'm hoping that the future will be bug-free :-D)

comment:3 Changed 4 years ago by ryandesign (Ryan Schmidt)

There are other open tickets about digikam build failures. I expect all users will experience them. Because you did not attach the complete main.log file, it's not possible to know whether your problem is identical to one of the already-known problems.

comment:4 Changed 22 months ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed

Nothing can be done here without a log. Feel free to reopen after attaching one.

Note: See TracTickets for help on using tickets.