Opened 15 years ago

Closed 15 years ago

#5218 closed defect (wontfix)

COMMENT: py-psycopg; use installed python when part of base system

Reported by: lbruno@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

py-psycopg-1.1.18

Since I already have a python installation in the base Mac OS X system, I've been wondering if you could add a variant to this port. Unless I'm mistaken, this would require a configure argument to select the installed python version.

What do you think?

Change History (1)

comment:1 Changed 15 years ago by mww@…

Resolution: wontfix
Status: newclosed
  1. The installed python is version 2.3 - Its hard enough already to ensure working ports for one version of

Python

  1. When Apple's python has issues, we can't do anything about it - we can only fix our own
  2. As soon as one port requires Python 2.4 AND e. g. psycopg, I have to make sure psycopg's python is

2.4;

Because of those two reasons - and the minimal drawbacks of wasting about 10MB of disk space of dp's Python 2.4 - we won't make this happen. If you don't like dp's Python, you may set your python search path to dp's python modules and try to use them with Apple's or another 3rd party's Python.

Note: See TracTickets for help on using tickets.