Opened 4 years ago

Closed 4 years ago

#52194 closed defect (fixed)

py27-html5lib should depend on py27-six

Reported by: bzbarsky (Boris Zbarsky) Owned by: lightnin@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: kurthindenburg (Kurt Hindenburg)
Port: py-html5lib

Description (last modified by mf2k (Frank Schima))

Trying to actually use html5lib after installing py27-html5lib gives me:

  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/html5lib/__init__.py", line 16, in <module>
    from .html5parser import HTMLParser, parse, parseFragment
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/html5lib/html5parser.py", line 2, in <module>
    from six import with_metaclass
ImportError: No module named six

Change History (3)

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to lightnin@…
Port: py-html5lib added; py27-html5lib removed

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers py27-html5lib), if any.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:3 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added
Resolution: fixed
Status: newclosed

done r153318

Note the latest b10 requires webencodings which isn't in macports

https://pypi.python.org/pypi/webencodings

Note: See TracTickets for help on using tickets.