Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#52207 closed defect (fixed)

ngrep @1.45: build failure with libpcap @1.8.0: no yacc restart func found

Reported by: marcel@… Owned by: grace@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: ryandesign (Ryan Schmidt), Schamschula (Marius Schamschula), kurthindenburg (Kurt Hindenburg)
Port: ngrep

Description

Please see attached build log.

Attachments (1)

main.log (4.6 KB) - added by marcel@… 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by marcel@…

Attachment: main.log added

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: sierra added
Owner: changed from macports-tickets@… to grace@…

That's not a clean log. Please clean and try again.

comment:2 Changed 3 years ago by ryandesign (Ryan Schmidt)

Here's the log from the buildbot. Looks like the problem is:

checking for pcap_open_live in -lpcap... yes
checking for pcap_restart in -lpcap... no
checking for pcap_yyrestart in -lpcap... no
checking for yyrestart in -lpcap... no
no yacc restart func found
perhaps libpcap wasn't compiled with bison/flex?

comment:3 Changed 3 years ago by ryandesign (Ryan Schmidt)

Cc: mps@… added
Keywords: sierra removed
Summary: ngrep @1.45 build fails on macOS Sierrangrep @1.45: build failure with libpcap @1.8.0: no yacc restart func found

Issue is not specific to Sierra.

The update of libpcap to 1.8.0 seems to have caused this. Don't know if it's a bug in ngrep or a bug in libpcap.

comment:4 in reply to:  2 Changed 3 years ago by Schamschula (Marius Schamschula)

Replying to ryandesign@…:

Here's the log from the buildbot. Looks like the problem is:

checking for pcap_open_live in -lpcap... yes
checking for pcap_restart in -lpcap... no
checking for pcap_yyrestart in -lpcap... no
checking for yyrestart in -lpcap... no
no yacc restart func found
perhaps libpcap wasn't compiled with bison/flex?

I can confirm that the symbol _yyrestart is not present in libpcap @1.8.0.

comment:5 Changed 2 years ago by miconda (Daniel-Constantin Mierla)

I was able to compile the ngrep on macos sierra by providing the option --disable-pcap-restart to the configure. All seems ok -- not sure for what the pcap yyrestart was used, but with some basic tests everything was ok.

I did (used verbosity flags to see where it fails and the commands it runs):

port -v clean ngrep
port -v -ddd install ngrep
cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_ngrep/ngrep/work/ngrep-1.45
 ./configure --prefix=/opt/local --with-pcap-includes=/opt/local/include --mandir=/opt/local/share/man --disable-pcap-restart
cd
port -v -ddd install ngrep

Maybe adding the extra configure flag is just enough for a fix of the macport.

Last edited 2 years ago by miconda (Daniel-Constantin Mierla) (previous) (diff)

comment:6 Changed 2 years ago by kurthindenburg (Kurt Hindenburg)

Cc: kurthindenburg added

comment:7 Changed 2 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

In d4a3c290/macports-ports:

ngrep: add various patches + use pcre

  • avoid sourceforge redirects
  • add openmaintainer for now - maintainer timeout
  • use macports pcre instead of ngrep's regex
  • use Debian's patches : ipv6, man, building, locale
  • enable-ipv6

closes #40792
closes #52840
closes #48123
closes #52207

comment:8 Changed 2 years ago by kurthindenburg (Kurt Hindenburg)

In 4c47444/macports-ports:

ngrep: add various patches + use pcre

  • avoid sourceforge redirects
  • add openmaintainer for now - maintainer timeout
  • use macports pcre instead of ngrep's regex
  • use Debian's patches : ipv6, man, building, locale
  • enable-ipv6

closes #40792
closes #52840
closes #48123
closes #52207

Note: See TracTickets for help on using tickets.