Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#52208 closed defect (fixed)

qt4-mac @4.8.7_4 fails to build on macOS Sierra

Reported by: herrbischoff (Marcel Bischoff) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version:
Keywords: sierra Cc: smeingast (Stefan Meingast), ATL-Flaneur (Andreas Yankopolus), dimkab, MaddTheSane (C.W. Betts), barrettsa@…, carlesfernandez (Carles Fernandez), michaellass (Michael Lass), roberthuston@…, szhorvat (Szabolcs Horvát)
Port: qt4-mac

Description

Please see attached build log.

Attachments (1)

main.log (4.1 KB) - added by herrbischoff (Marcel Bischoff) 5 years ago.

Download all attachments as: .zip

Change History (16)

Changed 5 years ago by herrbischoff (Marcel Bischoff)

Attachment: main.log added

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Keywords: sierra added
Owner: changed from macports-tickets@… to michaelld@…
Summary: qt4-mac @4.8.7 fails to build on macOS Sierraqt4-mac @4.8.7_4 fails to build on macOS Sierra
Version: 2.3.4

It seems that this is intentional. Michael will address this soon, I expect.

:error:fetch qt4-mac does not currently build on OSX later than 10.11 'El Capitan'.
:error:fetch org.macports.fetch for port qt4-mac returned: unsupported platform

comment:2 Changed 5 years ago by michaelld (Michael Dickens)

Once 10.12 is officially released and/or I have a public beta to build against & create a patch, then this issue will get fixed. I've heard the issue is just tweaking the Portfile and Qt4 configure script to handle 10.12 correctly. Since I don't have 10.12 right now, I can't say for certain. I'm happy to take patch recommendations ...

comment:3 Changed 5 years ago by macports@…

Using the public beta, which is now in GM, it seems to build fine. I just changed the line checking OS version, and didn't have any issues either compiling or using Qt4.

comment:4 Changed 5 years ago by smeingast (Stefan Meingast)

Cc: stefan.meingast@… added

Cc Me!

comment:5 Changed 5 years ago by ATL-Flaneur (Andreas Yankopolus)

Cc: andreas@… added

Cc Me!

comment:6 Changed 5 years ago by dimkab

Cc: dima.batenkov@… added

Cc Me!

comment:7 Changed 5 years ago by MaddTheSane (C.W. Betts)

Cc: computers57@… added

Cc Me!

comment:8 Changed 5 years ago by barrettsa@…

Cc: barrettsa@… added

Cc Me!

comment:9 Changed 5 years ago by carlesfernandez (Carles Fernandez)

Cc: carles.fernandez@… added

Cc Me!

comment:10 Changed 5 years ago by michaellass (Michael Lass)

Cc: bevan@… added

Cc Me!

comment:11 Changed 5 years ago by roberthuston@…

Cc: roberthuston@… added

Cc Me!

comment:12 Changed 5 years ago by michaelld (Michael Dickens)

I'm working on this. I might get a checkin tonight; more likely is tomorrow morning (US/Eastern). From what I've heard, it should be straight forward.

comment:13 Changed 5 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat@… added

Cc Me!

comment:14 Changed 5 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

committed in r153015.

comment:15 Changed 5 years ago by ATL-Flaneur (Andreas Yankopolus)

Thanks for the fix! This had been blocking the installation of Octave on Sierra.

Note: See TracTickets for help on using tickets.