Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#52228 closed defect (fixed)

osxfuse @2.8.2: build fails with Xcode 8.0

Reported by: herrbischoff (Marcel Bischoff) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: sierra Cc: e-t-h-a-n, tommac666@…, ryandesign (Ryan Schmidt), michaellass (Michael Lass), macports@…, szhorvat (Szabolcs Horvát), elventear (Pepe Barbe), nicolas.stransky@…, rjderosa (Robert De Rosa)
Port: osxfuse

Description

Additionally, there is no way to install it at all as long as there is no variant added for development versions.

Attachments (2)

main.log (312.5 KB) - added by herrbischoff (Marcel Bischoff) 5 years ago.
main.2.log (313.2 KB) - added by tommac666@… 5 years ago.
Error: org.macports.build for port osxfuse returned: command execution failed

Download all attachments as: .zip

Change History (20)

Changed 5 years ago by herrbischoff (Marcel Bischoff)

Attachment: main.log added

comment:1 Changed 5 years ago by mf2k (Frank Schima)

Keywords: sierra added
Owner: changed from macports-tickets@… to dports@…

In the future, please Cc the port maintainers (port info --maintainers osxfuse), if any.

comment:2 Changed 5 years ago by e-t-h-a-n

Cc: ethansherriff@… added

Cc Me!

comment:3 Changed 5 years ago by e-t-h-a-n

I'm trying to get osxfuse-3.5.0 working on Sierra. If I can get it working, I'll put a Portfile patch here!

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Has duplicate #52272.

The first problem—maybe the only problem—is that every new Xcode version needs to be whitelisted in the osxfuse build system. The last version whitelisted was 7.2, so 7.3 and 8.0 need to be added. There is a patch for 7.3 in another ticket.

comment:5 Changed 5 years ago by ryandesign (Ryan Schmidt)

Summary: osxfuse @2.8.2 build fails completely on macOS Sierraosxfuse @2.8.2: build fails with Xcode 8.0

comment:6 in reply to:  3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: tommac666@… added
Resolution: fixed
Status: newclosed

Replying to ethansherriff@…:

I'm trying to get osxfuse-3.5.0 working on Sierra. If I can get it working, I'll put a Portfile patch here!

Please attach it to #50588, not here.

Replying to ryandesign@…:

The first problem—maybe the only problem—is that every new Xcode version needs to be whitelisted in the osxfuse build system. The last version whitelisted was 7.2, so 7.3 and 8.0 need to be added. There is a patch for 7.3 in another ticket.

Fixed in r152811.

comment:7 Changed 5 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:8 in reply to:  7 Changed 5 years ago by tommac666@…

Replying to ryandesign@…:

Cc Me!

Is the port fixed ?
I still get a build error. I did make a

sudo port clean osxfuse

than

sudo port install osxfuse
Error: org.macports.build for port osxfuse returned: command execution failed 
Last edited 5 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 5 years ago by tommac666@…

Attachment: main.2.log added

Error: org.macports.build for port osxfuse returned: command execution failed

comment:9 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

I whitelisted Xcode 7.3 and 8.0, verified it worked with Xcode 7.3 on El Capitan, and committed it. Unfortunately it looks like there is an additional problem with Xcode 8 or Sierra. Our buildbot saw the same failure you did: https://build.macports.org/builders/ports-10.12_x86_64-builder/builds/4705

comment:10 Changed 5 years ago by neverpanic (Clemens Lang)

Has duplicate #52302.

comment:11 Changed 5 years ago by michaellass (Michael Lass)

Cc: bevan@… added

Cc Me!

comment:12 Changed 5 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:13 Changed 5 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat@… added

Cc Me!

comment:14 Changed 5 years ago by elventear (Pepe Barbe)

Cc: elventear@… added

Cc Me!

comment:15 Changed 5 years ago by nicolas.stransky@…

Cc: nicolas.stransky@… added

Cc Me!

comment:16 Changed 5 years ago by rjderosa (Robert De Rosa)

Cc: rderosa86@… added

Cc Me!

comment:17 Changed 5 years ago by drkp (Dan Ports)

Resolution: fixed
Status: reopenedclosed

Should be fixed by the update to 3.5.0 in r153090.

comment:18 Changed 5 years ago by herrbischoff (Marcel Bischoff)

Thank for updating! Please also see the issues with sshfs that I am having since the update: #52347

Note: See TracTickets for help on using tickets.