Opened 5 years ago

Closed 5 years ago

#52310 closed defect (duplicate)

qt5-qtbase does not configure on Mac OS X Sierra

Reported by: MacPorts@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: sierra Cc: mkae (Marko Käning), RJVB (René Bertin), szhorvat (Szabolcs Horvát), mamoll (Mark Moll), chutzpah (Christopher Hansen), mapsmehere@…, 3add3287 (3add3287), rickyzhang82 (Ricky Zhang)
Port: qt5-qtbase

Description

Here is how it goes at the command line:

> sudo port install qt5-qtbase
--->  Computing dependencies for qt5-qtbase
--->  Configuring qt5-qtbase
Error: org.macports.configure for port qt5-qtbase returned: configure failure: command execution failed
Please see the log file for port qt5-qtbase for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qt5-qtbase failed

Here is the log file:

version:1
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 502
:debug:main euid changed to: 506
:debug:main Executing org.macports.main (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.archivefetch (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.fetch (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.checksum (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.extract (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:main Skipping completed org.macports.patch (qt5-qtbase)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Wed Sep 21 19:18:23 PDT 2016
:notice:configure --->  Configuring qt5-qtbase
:debug:configure Using compiler 'Xcode Clang'
:debug:configure Executing org.macports.configure (qt5-qtbase)
:debug:configure Environment: 
CC='/usr/bin/clang'
CC_PRINT_OPTIONS='YES'
CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/.CC_PRINT_OPTIONS'
CPATH='/opt/local/include'
CXX='/usr/bin/clang++'
F77FLAGS='-m64'
F90FLAGS='-Os -m64'
FCFLAGS='-Os -m64'
FFLAGS='-Os'
INSTALL='/usr/bin/install -c'
LIBRARY_PATH='/opt/local/lib'
MACOSX_DEPLOYMENT_TARGET='10.12'
MAKE='/usr/bin/make'
OBJC='/usr/bin/clang'
OBJCXX='/usr/bin/clang++'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-opensource-src-5.6.1" && ./configure -prefix /opt/local/libexec/qt5 -bindir /opt/local/libexec/qt5/bin -headerdir /opt/local/libexec/qt5/include -libdir /opt/local/libexec/qt5/lib -archdatadir /opt/local/libexec/qt5 -plugindir /opt/local/libexec/qt5/plugins -importdir /opt/local/libexec/qt5/imports -qmldir /opt/local/libexec/qt5/qml -datadir /opt/local/libexec/qt5 -docdir /opt/local/libexec/qt5/doc -translationdir /opt/local/libexec/qt5/translations -sysconfdir /opt/local/libexec/qt5/etc/xdg -examplesdir /opt/local/libexec/qt5/examples -testsdir /opt/local/libexec/qt5/tests -hostdatadir /opt/local/libexec/qt5 -release -opensource -confirm-license -shared -largefile -accessibility -no-sql-db2 -no-sql-ibase -no-sql-mysql -no-sql-oci -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-sql-tds -platform macx-clang -no-testcocoon -no-gcov -force-pkg-config -system-zlib -no-mtdev -no-journald -no-syslog -system-libpng -system-libjpeg -system-freetype -system-harfbuzz -openssl-linked -no-libproxy -system-pcre --disable-xcb -no-xkbcommon-x11 -no-xkbcommon-evdev -no-xinput2 -no-xcb-xlib -glib -no-pulseaudio -no-alsa -no-gtkstyle -make libs -make tools -nomake examples -nomake tests -gui -widgets -no-rpath -verbose -nis -cups -iconv -no-evdev -no-tslib -icu -fontconfig -strip -no-pch -no-ltcg -dbus-linked -no-use-gold-linker -no-separate-debug-info -no-xcb -no-eglfs -no-gbm -no-directfb -no-linuxfb -no-kms -no-mirclient -no-libinput -no-gstreamer -no-system-proxies -framework -no-libudev -no-egl -no-openvg'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-opensource-src-5.6.1" && ./configure -prefix /opt/local/libexec/qt5 -bindir /opt/local/libexec/qt5/bin -headerdir /opt/local/libexec/qt5/include -libdir /opt/local/libexec/qt5/lib -archdatadir /opt/local/libexec/qt5 -plugindir /opt/local/libexec/qt5/plugins -importdir /opt/local/libexec/qt5/imports -qmldir /opt/local/libexec/qt5/qml -datadir /opt/local/libexec/qt5 -docdir /opt/local/libexec/qt5/doc -translationdir /opt/local/libexec/qt5/translations -sysconfdir /opt/local/libexec/qt5/etc/xdg -examplesdir /opt/local/libexec/qt5/examples -testsdir /opt/local/libexec/qt5/tests -hostdatadir /opt/local/libexec/qt5 -release -opensource -confirm-license -shared -largefile -accessibility -no-sql-db2 -no-sql-ibase -no-sql-mysql -no-sql-oci -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-sql-tds -platform macx-clang -no-testcocoon -no-gcov -force-pkg-config -system-zlib -no-mtdev -no-journald -no-syslog -system-libpng -system-libjpeg -system-freetype -system-harfbuzz -openssl-linked -no-libproxy -system-pcre --disable-xcb -no-xkbcommon-x11 -no-xkbcommon-evdev -no-xinput2 -no-xcb-xlib -glib -no-pulseaudio -no-alsa -no-gtkstyle -make libs -make tools -nomake examples -nomake tests -gui -widgets -no-rpath -verbose -nis -cups -iconv -no-evdev -no-tslib -icu -fontconfig -strip -no-pch -no-ltcg -dbus-linked -no-use-gold-linker -no-separate-debug-info -no-xcb -no-eglfs -no-gbm -no-directfb -no-linuxfb -no-kms -no-mirclient -no-libinput -no-gstreamer -no-system-proxies -framework -no-libudev -no-egl -no-openvg 
:info:configure 
:info:configure    Xcode not set up properly. You may need to confirm the license
:info:configure    agreement by running /usr/bin/xcodebuild without arguments.
:info:configure 
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-opensource-src-5.6.1" && ./configure -prefix /opt/local/libexec/qt5 -bindir /opt/local/libexec/qt5/bin -headerdir /opt/local/libexec/qt5/include -libdir /opt/local/libexec/qt5/lib -archdatadir /opt/local/libexec/qt5 -plugindir /opt/local/libexec/qt5/plugins -importdir /opt/local/libexec/qt5/imports -qmldir /opt/local/libexec/qt5/qml -datadir /opt/local/libexec/qt5 -docdir /opt/local/libexec/qt5/doc -translationdir /opt/local/libexec/qt5/translations -sysconfdir /opt/local/libexec/qt5/etc/xdg -examplesdir /opt/local/libexec/qt5/examples -testsdir /opt/local/libexec/qt5/tests -hostdatadir /opt/local/libexec/qt5 -release -opensource -confirm-license -shared -largefile -accessibility -no-sql-db2 -no-sql-ibase -no-sql-mysql -no-sql-oci -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-sql-tds -platform macx-clang -no-testcocoon -no-gcov -force-pkg-config -system-zlib -no-mtdev -no-journald -no-syslog -system-libpng -system-libjpeg -system-freetype -system-harfbuzz -openssl-linked -no-libproxy -system-pcre --disable-xcb -no-xkbcommon-x11 -no-xkbcommon-evdev -no-xinput2 -no-xcb-xlib -glib -no-pulseaudio -no-alsa -no-gtkstyle -make libs -make tools -nomake examples -nomake tests -gui -widgets -no-rpath -verbose -nis -cups -iconv -no-evdev -no-tslib -icu -fontconfig -strip -no-pch -no-ltcg -dbus-linked -no-use-gold-linker -no-separate-debug-info -no-xcb -no-eglfs -no-gbm -no-directfb -no-linuxfb -no-kms -no-mirclient -no-libinput -no-gstreamer -no-system-proxies -framework -no-libudev -no-egl -no-openvg 
:info:configure Exit code: 2
:error:configure org.macports.configure for port qt5-qtbase returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"portconfigure::configure_main org.macports.configure"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:configure Warning: targets not executed for qt5-qtbase: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:configure Failed to install qt5-qtbase
:debug:configure Registry error: qt5-sqlite-plugin not registered as installed & active.
    invoked from within
"registry_active $subport"
    invoked from within
"$workername eval registry_active \$subport"
:notice:configure Please see the log file for port qt5-qtbase for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtbase/main.log

I just finished upgrading to MacOS Sierra and was reinstalling all ports from scratch. Note also that qt4 won't even try to install on Sierra, naming El Capitan as the latest version it supports.

Attachments (1)

patch-no-xcrun-f-xcrun.diff (1.2 KB) - added by mkae (Marko Käning) 5 years ago.
Ran into the same issue, René's patch avoids the issue caused by xcrun

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

Cc: mcalhoun@… openmaintainer@… removed
Keywords: sierra added; Sierra removed
Owner: changed from macports-tickets@… to mcalhoun@…
Version: 2.3.4

comment:2 Changed 5 years ago by mkae (Marko Käning)

Cc: mk@… rjvbertin@… added

Changed 5 years ago by mkae (Marko Käning)

Attachment: patch-no-xcrun-f-xcrun.diff added

Ran into the same issue, René's patch avoids the issue caused by xcrun

comment:3 Changed 5 years ago by mkae (Marko Käning)

The patch solves the configure issue, but in build phase I run into:

But, I am running in a new thing now:

:info:configure /opt/local/var/macports/build/_Users_marko_WC_GIT_macstrop_aqua_qt5-kde/qt5-kde/work/qt-everywhere-opensource-src-5.6.1/qtbase/config.tests/common/libproxy/libproxy.cpp:36:10: fatal error: 'proxy.h' file not found
:info:configure #include <proxy.h>
:info:configure          ^
:info:configure 1 error generated.
:info:configure Makefile:206: recipe for target 'libproxy.o' failed
:info:configure gmake: *** [libproxy.o] Error 1
:info:configure libproxy disabled.

which probably deserves its own ticket...

Version 0, edited 5 years ago by mkae (Marko Käning) (next)

comment:4 Changed 5 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat@… added

Cc Me!

comment:5 Changed 5 years ago by mamoll (Mark Moll)

Cc: mmoll@… added

Cc Me!

comment:6 Changed 5 years ago by chutzpah (Christopher Hansen)

Cc: cphansen@… added

Cc Me!

comment:7 Changed 5 years ago by mkae (Marko Käning)

Note that qt4-mac can now be installed on Sierra, thanks to Michael: #52208!

comment:8 Changed 5 years ago by mapsmehere@…

Cc: mapsmehere@… added

Cc Me!

comment:9 Changed 5 years ago by mapsmehere@…

Which file do we patch?

comment:10 Changed 5 years ago by 3add3287 (3add3287)

Cc: torstenb@… added

Cc Me!

comment:11 Changed 5 years ago by rickyzhang82 (Ricky Zhang)

Cc: zhangchaowang@… added

Cc Me!

comment:12 in reply to:  9 Changed 5 years ago by rickyzhang82 (Ricky Zhang)

Replying to mapsmehere@…:

Which file do we patch?

I believe it is in diff file. Are there any concern to commit the patch?

comment:13 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #52200 to me. Feel free to reopen if I’m wrong.

Note: See TracTickets for help on using tickets.