Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52317 closed defect (duplicate)

ghc: depends on llvm-3.5, which is not supported on Sierra

Reported by: claus.atzenbeck@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version:
Keywords: sierra Cc: larryv (Lawrence Velázquez), szhorvat (Szabolcs Horvát)
Port: ghc

Description

I've updated to macOS Sierra and MacPorts 2.3.4. When doing a "sudo port upgrade outdated" (after "sudo port selfupdate"), I get the message that llvm-3.5 is not supported on macOS Sierra or newer (see below). How can this issue be resolved?

$ sudo port upgrade outdated
Password:
--->  Computing dependencies for llvm-3.5
--->  Fetching distfiles for llvm-3.5
Error: llvm-3.5 is not supported on macOS Sierra or newer.
Error: org.macports.fetch for port llvm-3.5 returned: unsupported platform
Please see the log file for port llvm-3.5 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_llvm-3.5/llvm-3.5/main.log
Error: Unable to upgrade port: 1

Change History (8)

comment:1 Changed 4 years ago by szhorvat (Szabolcs Horvát)

Cc: szhorvat@… added

Cc Me!

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Cc: larryv@… added
Owner: changed from macports-tickets@… to jeremyhu@…
Port: llvm-3.5 added

In the future, please fill in the Port field and Cc the port maintainers (port info --maintainers llvm-3.5), if any.

comment:3 Changed 4 years ago by larryv (Lawrence Velázquez)

Resolution: wontfix
Status: newclosed

This is intentional; we will not be supporting old versions of LLVM on Sierra.

If you use LLVM directly, you should switch to the latest version (llvm-3.9).

If not, you should find the port(s) that depend on it and reinstall them with the variant corresponding to the latest LLVM. What does this output?

$ port dependents llvm-3.5 clang-3.5

comment:4 Changed 4 years ago by claus.atzenbeck@…

Dependencies: llvm-3.5 <- ghc <- pandoc

I have removed all of those dependencies, which solved the problem. However, pandoc still depends on llvm-3.5. I guess that this will be changed in the future.

Thanks for the pointer.

comment:5 in reply to:  4 Changed 4 years ago by larryv (Lawrence Velázquez)

Keywords: sierra added
Port: ghc added; llvm-3.5 removed
Resolution: wontfix
Status: closedreopened
Summary: llvm-3.5 not supported on Sierraghc: depends on llvm-3.5, which is not supported on Sierra
Version: 2.3.4

comment:6 Changed 4 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: reopenedclosed

So this is a duplicate of #52221, which was folded into #48899.

comment:7 Changed 4 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Yeah, the following ports seem to have direct dependencies on fixed versions of llvm and should probably be looked at:

faust2-devel ghc julia pure py-llvmlite py-llvmpy

comment:8 Changed 4 years ago by mf2k (Frank Schima)

See #52424.

Note: See TracTickets for help on using tickets.