Opened 4 years ago

Closed 4 years ago

#52375 closed defect (duplicate)

inkscape-devel does not build under Sierra

Reported by: fleason (Fred Leason) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: inkscape-devel

Description (last modified by larryv (Lawrence Velázquez))

:info:build 	mv -f $depbase.Tpo $depbase.Po
:info:build box3d.cpp:793:17: warning: unused variable 'c3' [-Wunused-variable]
:info:build     Geom::Point c3(box3d_get_corner_screen(box, 3, false));
:info:build                 ^
:info:build 1 error generated.
:info:build make[3]: *** [main.o] Error 1
:info:build make[3]: *** Waiting for unfinished jobs....
:info:build 1 warning generated.
:info:build working tree is out of date, run 'bzr update'
:info:build 0.92pre1 r15023 custom

Attachments (1)

main.log (96.6 KB) - added by fleason (Fred Leason) 4 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_inkscape-devel/inkscape-devel/main.log

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by fleason (Fred Leason)

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_inkscape-devel/inkscape-devel/main.log

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…
Status: newassigned

When quoting console or logfile output, please use wiki:WikiFormatting to enhance readability.

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Resolution: duplicate
Status: assignedclosed
Summary: inkscape-devel does not build under Sierra - unused variable c3inkscape-devel does not build under Sierra
Version: 2.3.4

The bit you quoted is just a warning. The real error is unrelated and occurs beforehand:

:info:build In file included from main.cpp:33:
:info:build In file included from ./ui/widget/panel.h:20:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/box.h:59:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/container.h:30:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/widget.h:48:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/rc.h:31:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/style.h:46:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/iconset.h:35:
:info:build In file included from /opt/local/include/gtkmm-2.4/gtkmm/stockid.h:26:
:info:build In file included from /opt/local/include/glibmm-2.4/glibmm.h:89:
:info:build /opt/local/include/glibmm-2.4/glibmm/threads.h:209:11: error: field has incomplete type 'GThread' (aka '_GThread')
:info:build   GThread gobject_;
:info:build           ^
:info:build /opt/local/include/glib-2.0/glib/gthread.h:49:16: note: forward declaration of '_GThread'
:info:build typedef struct _GThread         GThread;

Duplicate of #52248.

Note: See TracTickets for help on using tickets.