Opened 4 years ago

Closed 4 years ago

#52397 closed defect (invalid)

Can't launch amarok on macOS Sierra

Reported by: iMiKED (iMiKE) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: amarok

Description

Successfully installed amarok on Sierra.

--->  Computing dependencies for openssl
--->  Fetching archive for openssl
Warning: Your DNS servers incorrectly claim to know the address of nonexistent hosts. This may cause checksum mismatches for some ports. See this page for more information: <https://trac.macports.org/wiki/MisbehavingServers>
--->  Attempting to fetch openssl-1.0.2j_0.darwin_16.x86_64.tbz2 from http://nue.de.packages.macports.org/openssl
--->  Attempting to fetch openssl-1.0.2j_0.darwin_16.x86_64.tbz2.rmd160 from http://nue.de.packages.macports.org/openssl
--->  Installing openssl @1.0.2j_0
--->  Cleaning openssl
--->  Computing dependencies for openssl
--->  Deactivating openssl @1.0.2i_0
--->  Cleaning openssl
--->  Activating openssl @1.0.2j_0
--->  Cleaning openssl
--->  Uninstalling openssl @1.0.2i_0
--->  Cleaning openssl
--->  Computing dependencies for amarok
--->  Fetching archive for amarok
--->  Attempting to fetch amarok-2.6.0_2+mariadb55.darwin_16.x86_64.tbz2 from http://nue.de.packages.macports.org/amarok
--->  Attempting to fetch amarok-2.6.0_2+mariadb55.darwin_16.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/amarok
--->  Attempting to fetch amarok-2.6.0_2+mariadb55.darwin_16.x86_64.tbz2 from http://lil.fr.packages.macports.org/amarok
--->  Fetching distfiles for amarok
--->  Verifying checksums for amarok
--->  Extracting amarok
--->  Applying patches to amarok
--->  Configuring amarok
--->  Building amarok
--->  Staging amarok into destroot
--->  Installing amarok @2.6.0_2+mariadb55
--->  Activating amarok @2.6.0_2+mariadb55

Don't forget that dbus needs to be started as the local user (not with sudo) before any KDE programs will launch.
To start it run the following command:
 launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist

--->  Cleaning amarok
--->  Updating database of binaries
--->  Scanning binaries for linking errors               
--->  No broken files found.                             

Cant't launch it:

-bash: amarok: command not found

So, what's up? How to launch it? Has it installed properly?

Change History (3)

comment:1 in reply to:  description Changed 4 years ago by larryv (Lawrence Velázquez)

Refresh your command hash table by running hash -r. Or just open a new terminal.

Does this mean we can close your earlier ticket #52389?

comment:2 Changed 4 years ago by iMiKED (iMiKE)

Yep, I think ticket #52389 can be closed now. Found Amarok under MacPorts group and launched successfully. Please, close this ticket also.

Last edited 4 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:3 in reply to:  2 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed

Replying to M-I-B@…:

Found Amarok under MacPorts group

I don't know what that means.

Note: See TracTickets for help on using tickets.