Opened 4 years ago

Closed 2 years ago

#52412 closed defect (fixed)

Update midori to use webkit2-gtk

Reported by: jeremyhu (Jeremy Huddleston Sequoia) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: midori

Description

Please update midori to use webkit2-gtk rather than webkit-gtk.

The older version of webkit-gtk hasn't been supported upstream for quite some time and is full of vulnerabilities.

See #52398

Change History (2)

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Owner: afb@… deleted
Status: newassigned

comment:2 Changed 2 years ago by dbevans (David B. Evans)

Owner: set to dbevans
Resolution: fixed
Status: assignedclosed

In 0ad64a86519eeb14d75dc3635fd405366b592616/macports-ports (master):

midori: update to version 7.0 using github, license, dependencies

Now uses gtk3 and webkit2-gtk.

Closes #52412

Note: See TracTickets for help on using tickets.