Opened 5 years ago

Closed 5 years ago

#52491 closed defect (duplicate)

ghc requires llvm-3.5, which is unsupported on macOS 10.12

Reported by: jowens@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: sierra Cc: jeremyhu (Jeremy Huddleston Sequoia), larryv (Lawrence Velázquez)
Port: ghc

Description (last modified by jowens@…)

$ sudo port upgrade ghc
--->  Computing dependencies for llvm-3.5
--->  Fetching distfiles for llvm-3.5
Error: llvm-3.5 is not supported on macOS Sierra or newer.

cc: llvm-3.5 owners. Not sure if this is a ghc issue or an llvm-3.5 issue.

Change History (4)

comment:1 Changed 5 years ago by jowens@…

Description: modified (diff)

comment:2 Changed 5 years ago by jowens@…

Keywords: sierra added

comment:3 Changed 5 years ago by jowens@…

Port: ghc added

comment:4 Changed 5 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

See #48899 and #52424.

Note: See TracTickets for help on using tickets.