#52549 closed defect (fixed)

gimp2 +quartz fails upgrade to @2.8.18_1

Reported by: mopihopi Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: quartz Cc:
Port: gimp2 epiphany gnome-desktop

Description

Upgrading gimp2 @2.8.18_0+python27+quartz to @2.8.18_1 fails, claiming that "gtk3 must be installed with +x11". However +quartz requires gtk3+quartz, which is incompatible with gtk3+x11.

~$ port outdated
The following installed ports are outdated:
gimp2                          2.8.18_0 < 2.8.18_1       
~$ port installed gimp2
The following ports are currently installed:
  gimp2 @2.8.18_0+python27+quartz (active)
~$ sudo port upgrade gimp2
--->  Computing dependencies for gnome-desktop
--->  Fetching archive for gnome-desktop
Error: org.macports.archivefetch for port gnome-desktop returned: gtk3 must be installed with +x11.
Please see the log file for port gnome-desktop for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_ykf.ca.distfiles.macports.org_mprelease_tarballs_ports_gnome_gnome-desktop/gnome-desktop/main.log
Error: Problem while installing gnome-desktop
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
~$ 

Change History (3)

comment:1 Changed 14 months ago by dbevans (David B. Evans)

  • Cc devans@… removed
  • Owner changed from macports-tickets@… to devans@…
  • Port epiphany gnome-desktop added
  • Status changed from new to assigned
  • Version 2.3.4 deleted

Will take a look. Note that the error is coming from gnome-desktop which is most definitely +x11 only -- it will not build +quartz. I believe this issue is a result of gimp2's new runtime dependency on epiphany which should go away soon. See also #52548.

comment:2 follow-up: Changed 14 months ago by mopihopi

Thanks. gnome-desktop was not (and is still not) installed, and I have no desire to install that.

comment:3 in reply to: ↑ 2 Changed 14 months ago by dbevans (David B. Evans)

  • Keywords quartz added
  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to mopihopi@…:

Thanks. gnome-desktop was not (and is still not) installed, and I have no desire to install that.

Exactly, gnome-desktop is not installed on your system because it will not build +quartz due to hard X11 dependencies. epiphany, in turn, will not build +quartz because of its dependency on gnome-desktop. Removing the runtime dependency on epiphany is, therefore, the necessary solution to your problem.

Fixed in r153733 without sacrificing the help functionality on +quartz builds. See #52548 for full details.

Note: See TracTickets for help on using tickets.