Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52602 closed defect (fixed)

git @2.10.1: fetch failed

Reported by: dliessi (Davide Liessi) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ci42, , ryandesign (Ryan Schmidt)
Port: git

Description

Relevant part of main.log:

:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://fco.it.distfiles.macports.org/mirrors/macports-distfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://lil.fr.distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from https://distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://nue.de.distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://osl.no.distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from https://www.kernel.org/pub/software/scm/git/
:debug:fetch Fetching distfile failed: Unknown SSL protocol error in connection to www.kernel.org:443 
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://sea.us.distfiles.macports.org/macports/distfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://jog.id.distfiles.macports.org/macports/distfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://cjj.kr.distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://aarnet.au.distfiles.macports.org/pub/macports/mpdistfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://nou.nc.distfiles.macports.org/pub/macports/distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://her.gr.distfiles.macports.org/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://jnb.za.distfiles.macports.org/distfiles/git
:debug:fetch Fetching distfile failed: Failed to connect to 2001:4200:fffc::248: No route to host
:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from http://svn.macports.org/repository/macports/distfiles/git
:debug:fetch Fetching distfile failed: The requested URL returned error: 404

The interesting bit is:

:notice:fetch --->  Attempting to fetch git-2.10.1.tar.gz from https://www.kernel.org/pub/software/scm/git/
:debug:fetch Fetching distfile failed: Unknown SSL protocol error in connection to www.kernel.org:443 

Change History (7)

comment:1 Changed 4 years ago by dbevans (David B. Evans)

Cc: ryandesign@… added

There are known problems with SSL fetches on 10.5 and earlier. Current workaround according to ryandesign is to rely on fetching from our distfiles mirrors. Currently the distfiles mirrors are updated twice a week so, in this case, they may not have done so as yet. The plan is to switch to updating these mirrors on each commit but that hasn't happened yet.

See also #52528.

Am I right in guessing that you're using 10.5 or earlier? If so, this is a duplicate of that ticket.

comment:2 Changed 4 years ago by dliessi (Davide Liessi)

I'm using 10.6.8.

comment:3 Changed 4 years ago by dbevans (David B. Evans)

Well, this may be something else then. Can you fetch the distfile manually using your web browser? How about curl/wget?

comment:4 Changed 4 years ago by dbevans (David B. Evans)

FWIW, fetch of git distfile using port works for me on my 10.11 system

--->  Attempting to fetch git-2.10.1.tar.gz from https://www.kernel.org/pub/software/scm/git/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 5915k  100 5915k    0     0  5756k      0  0:00:01  0:00:01 --:--:-- 5760k
--->  Attempting to fetch git-manpages-2.10.1.tar.gz from https://www.kernel.org/pub/software/scm/git/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  621k  100  621k    0     0  4790k      0 --:--:-- --:--:-- --:--:-- 4816k

and curl and wget work as well.

comment:5 Changed 4 years ago by dliessi (Davide Liessi)

I was able to fetch the distfile manually with the web browser and with both curl and wget.

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Each new version of Mac operating system includes newer versions of curl and openssl. It is definitely possible to configure a web server in such a restrictive way that only very new versions of curl and openssl can access it. That is what the administrators of kernel.org appear to have done. I am able to access kernel.org from Mavericks and later, but not Mountain Lion or earlier.

So this is a known problem with nothing else to do other than what's already planned elsewhere.

Duplicate of #51516.

comment:7 Changed 4 years ago by raimue (Rainer Müller)

Resolution: duplicatefixed

In 7a428704/macports-ports:

git: add alternative download URL to master_sites

The main server at www.kernel.org has a hard requirement for TLS 1.2,
which is not available on older versions of macOS. This CDN mirror is
less restrictive and can be accessed using TLS 1.0.

Closes: #52602
Closes: #52604
Closes: #52836
See: #51516

Note: See TracTickets for help on using tickets.