Opened 14 months ago

Last modified 3 months ago

#52603 new defect

HandBrakeCLI @0.10.0: Fails to build on OS X 10.11.6

Reported by: juandesant (Juande Santander-Vela) Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: elcapitan sierra Cc:
Port: HandBrakeCLI

Description (last modified by ryandesign (Ryan Schmidt))

When installing HandBrakeCLI, it fails with the following error:

:info:configure configure.py: error: invalid xcconfig: osx1011.x86_64 (choose from: native none osx1010.i386 osx1010.x86_64 osx106.i386 osx106.x86_64 osx107.i386 osx107.x86_64 osx108.i386 osx108.x86_64 osx109.i386 osx109.x86_64 supplemental)

It seems that osx1011 is not supported.

ps. It does not work neither with

sudo port install HandBrakeCLI

nor

sudo port -t install HandBrakeCLI

Attachments (1)

main.log (82.9 KB) - added by juandesant (Juande Santander-Vela) 14 months ago.
Log file for HandBrakeCLI

Download all attachments as: .zip

Change History (6)

Changed 14 months ago by juandesant (Juande Santander-Vela)

Log file for HandBrakeCLI

comment:1 Changed 14 months ago by juandesant (Juande Santander-Vela)

  • Cc juandesant@… added

Cc Me!

comment:2 Changed 14 months ago by ryandesign (Ryan Schmidt)

  • Cc juandesant@… removed
  • Description modified (diff)
  • Keywords elcapitan sierra added
  • Owner changed from macports-tickets@… to larryv@…

comment:3 Changed 14 months ago by gsulshski (Greg Ulsh)

I have the same problem.

comment:4 Changed 14 months ago by stanimura

On OS X 10.12.1, I have the same problem.

configure.py: error: invalid xcconfig: osx1012.x86_64 (choose from: native none osx1010.i386 osx1010.x86_64 osx106.i386 osx106.x86_64 osx107.i386 osx107.x86_64 osx108.i386 osx108.x86_64 osx109.i386 osx109.x86_64 supplemental)

Indeed, there is not osx1012.x86_64.xcconfig in HandBrake-0.10.0/macosx/xcconfig/.

Last edited 14 months ago by stanimura (previous) (diff)

comment:5 Changed 3 months ago by knlr

I just failed to install on 10.12. Seeing this bug is already 10 months old, it looks like this port is not being maintained any longer?

Note: See TracTickets for help on using tickets.