Opened 4 years ago

Closed 3 years ago

#52611 closed defect (fixed)

mongodb @3.2.10_0: error: chosen constructor is explicit in copy-initialization

Reported by: bakki Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: lion mountainlion mavericks Cc:
Port: mongodb

Description (last modified by ryandesign (Ryan Schmidt))

OSX v.10.9.5

port -v install mongodb fails with

4 errors generated.
scons: *** [build/MP/mongo/dbtests/index_access_method_test.o] Error 1
scons: building terminated because of errors.
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mongodb/mongodb/work/mongodb-src-r3.2.10" && /opt/local/bin/scons -j4 all mongobridge mongosniff CC="/usr/bin/clang" CCFLAGS="-arch x86_64" CPPPATH="/opt/local/include" CXX="/usr/bin/clang++" LIBPATH="/opt/local/lib" LINKFLAGS="-arch x86_64" TARGET_ARCH=x86_64 --disable-warnings-as-errors --libc++ --osx-version-min=10.9 --ssl --wiredtiger=on VARIANT_DIR=MP 
Exit code: 2
Error: org.macports.build for port mongodb returned: command execution failed
Warning: targets not executed for mongodb: org.macports.activate org.macports.build org.macports.destroot org.macports.install
Please see the log file for port mongodb for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_databases_mongodb/mongodb/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port mongodb failed

Attachments (1)

main.log (677.4 KB) - added by bakki 4 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: mongodb removed

Please attach the main.log so we can see why it failed for you.

Changed 4 years ago by bakki

Attachment: main.log added

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

Keywords: lion mountainlion mavericks added
Owner: changed from macports-tickets@… to ryandesign@…
Status: newassigned
Summary: Error building mongodb upgrading 3.2.9_0 < 3.2.10_0mongodb @3.2.10_0: error: chosen constructor is explicit in copy-initialization

Thanks. I can confirm our automated build system had the same error, in Mavericks build 6419, Mountain Lion legacy build 6365 and Lion legacy build 11547.

comment:4 Changed 3 years ago by kencu (Ken)

Cleaning up old lion tickets.

This ticket is marked as FIXED upstream, and the buildbots report that the current mongodb 3.4.6 builds on Lion now, and on 10.9 through 10.12, but for as yet unknown reason did not build on 10.6 or 10.8.

comment:5 Changed 3 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed

The port has already been marked as incompatible with 10.6 for a long time; see #47119. The developers indicated the change in minimum OS X version was intentional. The initial problem was the lack of strnlen, which we could probably address these days with the snowleopard_fixes portgroup, but libc++ would be needed as well, and possibly other issues might have arisen in the years since then as well. In any case, it's not relevant to this ticket; if you want to revive 10.6 support for mongodb, it can be in another ticket or PR.

The build failure on 10.8 now is a different problem, which I've been working on with the developers in https://jira.mongodb.org/browse/SERVER-31016. I just haven't had time to test the proposed fix on 10.7, but will try to do so today.

Note: See TracTickets for help on using tickets.