Opened 4 years ago

Closed 4 years ago

#52618 closed defect (duplicate)

gnuregex not building in Tiger

Reported by: herminio.hernandezjr@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: tiger Cc:
Port: gnuregex

Description

I am trying to build gnuregex, but is failing to compile. Below is a portion of the logfile. I know that Tiger is really old and would like to know if it is even possible that this program will build.

:debug:build Executing proc-post-org.macports.build-build-0
:debug:build libtool -lSystem -dynamic -install_name /opt/local/lib/libgnuregex.dylib -o libgnuregex.dylib regex.o
:info:build ld: symbol dyld_stub_binding_helper not defined (usually in crt1.o/dylib1.o/bundle1.o) for architecture ppc
:info:build fatal error: libtool: internal link edit command failed
:info:build Command failed: cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_gnuregex/gnuregex/work/regex-0.12 && libtool -lSystem -dynamic -install_name /opt/local/lib/libgnuregex.dylib -o libgnuregex.dylib regex.o
:info:build Exit code: 1
:error:build org.macports.build for port gnuregex returned: command execution failed
:debug:build Error code: NONE
:debug:build Backtrace: command execution failed
    while executing
"proc-post-org.macports.build-build-0 org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $post $targetname"
:info:build Warning: targets not executed for gnuregex: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port gnuregex for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_gnuregex/gnuregex/main.log

Change History (1)

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

Keywords: tiger added
Port: gnuregex added
Resolution: duplicate
Status: newclosed

I was working on this problem.

Duplicate of #52466.

Note: See TracTickets for help on using tickets.