Opened 4 years ago

Closed 4 years ago

#52620 closed defect (fixed)

qt5-docs build error on Sierra

Reported by: ken-cunningham-webuse Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: sierra Cc: mkae (Marko Käning)
Port: qt5-docs

Description

Hello. I was surprised not to see this in the tickets already, as I suspect I'm not the first to see this. Did I miss it?

Most parts of qt5 installed from the buildbots after a Sierra upgrade, but two did not (docs and webengine). I see this error with qt5-docs, which I thought was likely due to the missing xcrun program:

--->  Fetching distfiles for qt5-docs
Warning: OS X subsequent to 10.10 (Yosemite) is not a Reference Configuration for Qt.
Warning: See http://doc.qt.io/qt-5/supported-platforms.html#reference-configurations
--->  Verifying checksums for qt5-docs
--->  Checksumming qt-everywhere-opensource-src-5.6.1.tar.xz
--->  Extracting qt5-docs
--->  Extracting qt-everywhere-opensource-src-5.6.1.tar.xz
xinstall: mkdir /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-docs/work/qt-everywhere-opensource-src-5.6.1/qttools/bin
--->  Configuring qt5-docs
+ cd qtbase
+ /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-docs/work/qt-everywhere-opensource-src-5.6.1/qtbase/configure -top-level -prefix /opt/local/libexec/qt5 -bindir /opt/local/libexec/qt5/bin -headerdir /opt/local/libexec/qt5/include -libdir /opt/local/libexec/qt5/lib -archdatadir /opt/local/libexec/qt5 -plugindir /opt/local/libexec/qt5/plugins -importdir /opt/local/libexec/qt5/imports -qmldir /opt/local/libexec/qt5/qml -datadir /opt/local/libexec/qt5 -docdir /opt/local/libexec/qt5/doc -translationdir /opt/local/libexec/qt5/translations -sysconfdir /opt/local/libexec/qt5/etc/xdg -examplesdir /opt/local/libexec/qt5/examples -testsdir /opt/local/libexec/qt5/tests -hostdatadir /opt/local/libexec/qt5 -release -opensource -confirm-license -shared -largefile -accessibility -no-sql-db2 -no-sql-ibase -no-sql-mysql -no-sql-oci -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-sql-tds -platform macx-clang -no-testcocoon -no-gcov -force-pkg-config -system-zlib -no-mtdev -no-journald -no-syslog -system-libpng -system-libjpeg -system-freetype -system-harfbuzz -openssl-linked -no-libproxy -system-pcre --disable-xcb -no-xkbcommon-x11 -no-xkbcommon-evdev -no-xinput2 -no-xcb-xlib -glib -no-pulseaudio -no-alsa -no-gtkstyle -make libs -make tools -nomake examples -nomake tests -gui -widgets -no-rpath -verbose -nis -cups -iconv -no-evdev -no-tslib -icu -fontconfig -strip -no-pch -no-ltcg -dbus-linked -no-use-gold-linker -no-separate-debug-info -no-xcb -no-eglfs -no-gbm -no-directfb -no-linuxfb -no-kms -no-mirclient -no-libinput -no-gstreamer -no-system-proxies -framework -no-libudev -no-egl -no-openvg

   Xcode not set up properly. You may need to confirm the license
   agreement by running /usr/bin/xcodebuild without arguments.

Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-docs/work/qt-everywhere-opensource-src-5.6.1" && ./configure -prefix /opt/local/libexec/qt5 -bindir /opt/local/libexec/qt5/bin -headerdir /opt/local/libexec/qt5/include -libdir /opt/local/libexec/qt5/lib -archdatadir /opt/local/libexec/qt5 -plugindir /opt/local/libexec/qt5/plugins -importdir /opt/local/libexec/qt5/imports -qmldir /opt/local/libexec/qt5/qml -datadir /opt/local/libexec/qt5 -docdir /opt/local/libexec/qt5/doc -translationdir /opt/local/libexec/qt5/translations -sysconfdir /opt/local/libexec/qt5/etc/xdg -examplesdir /opt/local/libexec/qt5/examples -testsdir /opt/local/libexec/qt5/tests -hostdatadir /opt/local/libexec/qt5 -release -opensource -confirm-license -shared -largefile -accessibility -no-sql-db2 -no-sql-ibase -no-sql-mysql -no-sql-oci -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-sql-tds -platform macx-clang -no-testcocoon -no-gcov -force-pkg-config -system-zlib -no-mtdev -no-journald -no-syslog -system-libpng -system-libjpeg -system-freetype -system-harfbuzz -openssl-linked -no-libproxy -system-pcre --disable-xcb -no-xkbcommon-x11 -no-xkbcommon-evdev -no-xinput2 -no-xcb-xlib -glib -no-pulseaudio -no-alsa -no-gtkstyle -make libs -make tools -nomake examples -nomake tests -gui -widgets -no-rpath -verbose -nis -cups -iconv -no-evdev -no-tslib -icu -fontconfig -strip -no-pch -no-ltcg -dbus-linked -no-use-gold-linker -no-separate-debug-info -no-xcb -no-eglfs -no-gbm -no-directfb -no-linuxfb -no-kms -no-mirclient -no-libinput -no-gstreamer -no-system-proxies -framework -no-libudev -no-egl -no-openvg 
Exit code: 2
Error: org.macports.configure for port qt5-docs returned: configure failure: command execution failed
Warning: targets not executed for qt5-docs: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port qt5-docs failed

of course, running $ /usr/bin/xcodebuild without arguments did not fix the issue:

xcodebuild: error: The directory / does not contain an Xcode project.

I tried a simple fix, reinplacing xcrun with xcodebuild in the qtbase configure script (subport docs)

    post-extract {
        # generated makefiles assume full Qt was built locally
        xinstall -d -m 0755                 ${worksrcpath}/qttools/bin/
        ln -s ${qt_bins_dir}/qdoc           ${worksrcpath}/qttools/bin/
        ln -s ${qt_bins_dir}/qhelpgenerator ${worksrcpath}/qttools/bin/
        ln -s ${qt_bins_dir}/rcc            ${worksrcpath}/qtbase/bin/
        reinplace "s|xcrun|xcodebuild|g" ${worksrcpath}/qtbase/configure

    }

and although the build then proceeded considerably farther along the path to success, it ultimately failed with the following

(full build log attached):

Running configuration tests (phase 2)...
Failed to process makespec for platform 'macx-clang'

so - not sure just what is the next step now.

Apologies if this turns out to be a duplicate that I have missed.

Attachments (1)

qt5-docs-build-fail.log.gz (11.7 KB) - added by ken-cunningham-webuse 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by ken-cunningham-webuse

Attachment: qt5-docs-build-fail.log.gz added

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

This was supposed to have been fixed 2 weeks ago. See #52200. Are your ports up to date? (sudo port selfupdate)

comment:2 Changed 4 years ago by ken-cunningham-webuse

Oh, I thought I was. Hope it wasn't something that stupid. Will double check. - (have a lot of machines building ports around here these days)

comment:3 Changed 4 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:4 Changed 4 years ago by ken-cunningham-webuse

nope - freshly updated, but unfortunately qt5-docs still fails. I guess they must be failing on the buildbot too, as I didn't download them prebuilt?

The ports tree has been updated. To upgrade your installed ports, you should run
  port upgrade outdated
$ port outdated
No installed ports are outdated.
$ sudo port install qt5-docs
--->  Computing dependencies for qt5-docs
--->  Extracting qt5-docs
--->  Configuring qt5-docs
Error: org.macports.configure for port qt5-docs returned: configure failure: command execution failed
Please see the log file for port qt5-docs for details:

I notice I have a /usr/bin/xcrun again -- I had thought that was gone when I upgraded to Xcode 8 on El Cap (generating those qt build errors), but I see it here now on Sierra.

-rwxr-xr-x   1 root  wheel   23920 13 Sep 17:57 xcode-select
-rwxr-xr-x   1 root  wheel   18256 13 Sep 17:56 xcodebuild
-rwxr-xr-x   1 root  wheel   17904 13 Sep 17:56 xcrun
-rwxr-xr-x   1 root  wheel   18256 13 Sep 17:56 xcscontrol
-rwxr-xr-x   1 root  wheel   18272 13 Sep 17:56 xcsdiagnose
-rwxr-xr-x   1 root  wheel   18240 13 Sep 17:56 xed

comment:5 Changed 4 years ago by ken-cunningham-webuse

I think I know what might be going on. I never built qt5-base -- it was downloaded and installed from a prebuilt binary -- so I presume I never built qmake and I never got the patched version of the default_pre.prf.

I tried to add the patchfile to the docs section of the portfile, but the file locations weren't correct.

to install qt5-docs, I manually applied the xcrun -> xcodebuild change detailed in 52200 to

qt5-docs/work/qt-everywhere-opensource-src-5.6.1/qtbase/configure

and to

qt5-docs/work/qt-everywhere-opensource-src-5.6.1/qtbase/mkspecs/features/mac/default_pre.prf

and then all was well, and the install completed... with a lot of warnings in the process (screenfuls of them), I might add.

$ port -v installed | grep qt5-docs
  qt5-docs @5.6.1_0 (active) platform='darwin 16' archs='x86_64'
Last edited 4 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: mcalhoun@… removed
Keywords: sierra added; Sierra removed
Owner: changed from macports-tickets@… to mcalhoun@…

comment:7 Changed 4 years ago by ryandesign (Ryan Schmidt)

See also #52647.

comment:8 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

Thank you for the bug report.
If I understand correctly, you managed to fix the problem manually for yourself.
Hopefully, r154312 fixes the problem for everyone else.

Note: See TracTickets for help on using tickets.