Opened 5 years ago

Closed 5 years ago

#52660 closed defect (duplicate)

qt5-qtwebkit fails to upgrade to 5.5.1_5 on Sierra

Reported by: mouse07410 (Mouse) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: sierra Cc: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez), raimue (Rainer Müller), mkae (Marko Käning)
Port: qt5-qtwebkit

Description

     qt5-qtwebkit @5.5.1 
--->  Computing dependencies for qt5-qtwebkit
--->  Configuring qt5-qtwebkit
Error: org.macports.configure for port qt5-qtwebkit returned: configure failure: command execution failed
Please see the log file for port qt5-qtwebkit for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_qt5/qt5-qtwebkit/main.log
Error: Unable to upgrade port: 1
Error rebuilding qt5-qtwebkit
    while executing
"error "Error rebuilding $portname""
    (procedure "revupgrade_scanandrebuild" line 395)
    invoked from within
"revupgrade_scanandrebuild broken_port_counts $opts"
    (procedure "macports::revupgrade" line 5)
    invoked from within
"macports::revupgrade $opts"
    (procedure "action_revupgrade" line 2)
    invoked from within
"action_revupgrade $action $portlist $opts"
    (procedure "action_target" line 96)
    invoked from within
"$action_proc $action $portlist [array get global_options]"
    (procedure "process_cmd" line 103)
    invoked from within
"process_cmd $remaining_args"
    invoked from within
"if { [llength $remaining_args] > 0 } {

    # If there are remaining arguments, process those as a command
    set exit_status [process_cmd $remaining..."
    (file "/opt/local/bin/port" line 5268)

Attachments (1)

qt5-qtwebkit.log.txt (17.8 KB) - added by mouse07410 (Mouse) 5 years ago.
Complete Macports log of qt5-qtwebkit failed build

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by mouse07410 (Mouse)

Attachment: qt5-qtwebkit.log.txt added

Complete Macports log of qt5-qtwebkit failed build

comment:1 Changed 5 years ago by raimue (Rainer Müller)

Cc: raimue@… added
Keywords: sierra added; Sierra removed
:info:configure Project ERROR: Xcode not set up properly. You may need to confirm the license agreement by running /usr/bin/xcodebuild.

Did you accept the Xcode license? Either open Xcode at least once or run xcodebuild -license.

Although normally MacPorts should detect the situation when you did not accept it yet and print a more helpful error message.

comment:2 Changed 5 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:3 Changed 5 years ago by mouse07410 (Mouse)

I wish it were so simple. Not only did I accept the Xcode license - I've reported a wrong OS version!!!

Unfortunately, this is on El Capitan, 10.11.6.

No, unfortunately the problem is with the latest qt5-qtwebkit update.

comment:4 Changed 5 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #52647. See also #52620 and #52200.

Note: See TracTickets for help on using tickets.