Opened 4 years ago

Closed 4 years ago

#52682 closed defect (worksforme)

gpredict @1.3.2: Runnin 100% CPU after `killall`

Reported by: rubendibattista (Ruben Di Battista) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: zapman@…
Port: gpredict

Description (last modified by mf2k (Frank Schima))

Hello, I installed gpredict on my MBP (10.11.6). It was working fine. Then I created a new visualization module and filled it with satellites. It froze (don't know the actual reason, maybe wrong parameters of the ground station). So I killed gpredict killall -KILL gpredict. Now everytime I run gpredict it runs 100% CPU and the GUI is not showing up.

What I tried:

  1. Uninstall, Clean, Install
  2. Reboot
  3. Update X11 (2.7.10)
  4. Update Ports

Could be that there is some file where the visualization module is saved and it keeps trying to load it. Where does gpredict save visualization modules?

Attachments (1)

Schermata 2016-10-23 alle 16.50.55.png (32.7 KB) - added by rubendibattista (Ruben Di Battista) 4 years ago.
Screenshot

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by rubendibattista (Ruben Di Battista)

Screenshot

comment:1 Changed 4 years ago by rubendibattista (Ruben Di Battista)

Ok, Solved.

Gpredict is storing configuration file in ~/.config/Gpredict. Removing the directory made gpredict great again! :P

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.