Opened 15 years ago

Closed 14 years ago

#5269 closed defect (fixed)

cvsfetch and svnfetch in portfetch.tcl never download $patchfiles.

Reported by: yeled@… Owned by: yeled@…
Priority: Normal Milestone:
Component: base Version: 1.0
Keywords: Cc: ranger@…, jberry@…
Port:

Description

Portfile: http://paste.lisp.org/display/12226#1 (please read the annotation)

This Portfile, in HEAD and 1.02 will not download the +cvs patchfile as `proc cvsfetch' is not the same as proc fetchfiles'. It misses the parts about all_dist_files' I think, and therefore `proc checkfiles'.

If you omit +cvs and just build +smtp, the correct patchfile is built.

I don't believe this is in the trivial side of fixing. hence no patch from me :)

Change History (15)

comment:1 Changed 15 years ago by yeled@…

Summary: cvsfetch and svnfetch in portfetch.tcl don't always download $patchfiles.cvsfetch and svnfetch in portfetch.tcl never download $patchfiles.

comment:2 Changed 15 years ago by jberry@…

Hmm. I'm still trying to grok what the right thing to do would be. This isn't high on my priority list, for whatever reason... ;)

I wonder if it would be right to run checkfiles/fetchfiles also for cvs and svn, but in checkfiles only add patchfiles to the list of urls to fetch, not distfiles?

comment:3 Changed 15 years ago by yeled@…

yes - exactly what needs to happen.

my Tcl-fu is so so weak. I've discovered that Tcl cuts and pastes a whole lot less easily than C.

comment:4 Changed 15 years ago by jberry@…

(In reply to comment #2)

I've discovered that Tcl cuts and pastes a whole lot less easily than C.

Does that imply you're working on this bug? ;)

comment:5 Changed 15 years ago by yeled@…

(In reply to comment #3)

(In reply to comment #2)

I've discovered that Tcl cuts and pastes a whole lot less easily than C.

Does that imply you're working on this bug? ;)

it implies i've been working on it. But I imagine the few hours I've spent trying to hack Tcl into working for me.. and the open browser windows i have on Tcl documentation could all be cut short by someone who knows what they are doing.

However - if I can save your time by using you - or anyone else - as a mentor - I will take this bug on myself.

comment:6 Changed 15 years ago by jberry@…

However - if I can save your time by using you - or anyone else - as a mentor - I will take this bug on myself.

Hi Charlie,

I'd be happy to mentor you. I'm probably not inclined to fix this bug, myself, for this release, but if you go after it I'm happy to help you out. Just be aware that the sooner it gets fixed, the more likely it is to get into the 1.2 release. I know how you feel about tcl--it's quite a bit different. I was there myself not long ago, and I still don't have a good feel for some corners of it. There's times I wish dp was written in something else, though the flexibility in the portfile syntax is relatively cool. Ruby might have been a good choice, but it's equally obscure.

Let's touch base off-line about this bug. -jdb

comment:7 Changed 15 years ago by jberry@…

See also bug #634. Apart from patch files, is there ever a reason to do fetchfiles and cvsfetch?

comment:8 Changed 15 years ago by jberry@…

Cc: ranger@… added

* Bug 634 has been marked as a duplicate of this bug. *

comment:9 Changed 15 years ago by yeled@…

Status: newassigned

(In reply to comment #6)

See also bug #634. Apart from patch files, is there ever a reason to do fetchfiles and cvsfetch?

I can see no reason myself, however it is used in this Portfile: audio/arts/Portfile

variant cvs {

##### THIS IS UNSUPPORTED, DO NOT USE THIS IN YOUR PORTS! ##### cvs.root :pserver:anonymous@anoncvs.kde.org:/home/kde cvs.module arts pre-extract cvsfetch ##### I MEAN IT, LANDONF WILL KILL YOU IF YOU DO THIS! #####

distname arts version 1.2.0 distfiles kde-admindir-cvs-20030701.tar.bz2:admin checksums kde-admindir-cvs-20030701.tar.bz2 md5 b9bf2dc286d2e434c2cfdadc421c79b6 patchfiles

} <<<<

Do you understand what he's doing here? Man that Portfile is ugly.

comment:10 Changed 15 years ago by toby@…

severity: criticalnormal

comment:11 Changed 15 years ago by ranger@…

Do you understand what he's doing here? Man that Portfile is ugly.

Yeah it is. :)

There was a time at which I was doing KDE development straight from portfiles; if you used the cvs variant it would build whatever it happened to check out of CVS head.

It's old, crufty, and rather silly nowadays (since KDE doesn't take nearly as much coercing to build on Darwin). I'd say unless you're using it (and no one is, I'm reasonably sure), dump it.

comment:12 Changed 14 years ago by yeled@…

Cc: jberry@… added

wow.

if {[info exists patchfiles]} { return [fetchfiles] }

at the end of the cvsfetch proc does it.

is this an acceptable fix?

comment:13 Changed 14 years ago by jberry@…

Charlie,

I guess that's okay, as long as it works ;) You probably want the same thing at the end of svnfetch? Man that fetch code is ugly!

comment:14 Changed 14 years ago by yeled@…

Owner: changed from darwinports-bugs@… to yeled@…
Status: assignednew

turns out i changed something and deleted the change (and now doesnt work anymore) - so i dont really understand it after all.

comment:15 Changed 14 years ago by yeled@…

Resolution: fixed
Status: newclosed

well the final code is uglier. i must have had a clean breakthrough last night, but i cant replicate it now. so it's this mess.

Note: See TracTickets for help on using tickets.