Opened 4 years ago

Closed 4 years ago

#52697 closed defect (duplicate)

OpenCV on Mac OS Sierra failed to build

Reported by: jooni41 Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version:
Keywords: sierra Cc: mkae (Marko Käning), RJVB (René Bertin)
Port: opencv

Description (last modified by larryv (Lawrence Velázquez))

I tried to install nonfree module of opencv to openCV with python bindings by:

sudo port install opencv +contrib +py27

but it gives the following error

Error: org.macports.build for port opencv returned: command execution failed
The log file states:
info:build [ 44%] Built target opencv_dnn
:info:build 1 warning generated.
:info:build make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/build'
:info:build make[1]: *** [modules/videoio/CMakeFiles/opencv_videoio.dir/all] Error 2
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/build'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/

Attachments (2)

main.log (99.2 KB) - added by jooni41 4 years ago.
log_file
main.2.log (159.5 KB) - added by jooni41 4 years ago.
when I ran the command 2nd time

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 years ago by larryv (Lawrence Velázquez)

Component: contribports
Description: modified (diff)
Owner: changed from macports-tickets@… to stromnov
Priority: HighNormal
Status: newassigned

Please run sudo port clean opencv && sudo port install opencv +contrib +python27 and attach the log file.

comment:2 Changed 4 years ago by jooni41

Log file is larger then the upper limit thats why i just added part of it

comment:3 in reply to:  2 Changed 4 years ago by larryv (Lawrence Velázquez)

So compress it and attach the compressed version.

Changed 4 years ago by jooni41

Attachment: main.log added

log_file

Changed 4 years ago by jooni41

Attachment: main.2.log added

when I ran the command 2nd time

comment:4 Changed 4 years ago by mkae (Marko Käning)

Cc: mkae added

comment:5 Changed 4 years ago by mkae (Marko Käning)

Cc: RJVB added
Version: 2.3.4

RJVB came up with a patch. Will post it soonish here for review by stromnov.

comment:6 Changed 4 years ago by mkae (Marko Käning)

Keywords: sierra added

comment:7 Changed 4 years ago by mkae (Marko Käning)

Resolution: duplicate
Status: assignedclosed

Is duplicate of #52328

Note: See TracTickets for help on using tickets.