Opened 18 years ago

Closed 17 years ago

Last modified 16 years ago

#527 closed defect (fixed)

viewcvs port incorrectly references $workpath in numerous internal files

Reported by: landonf@… Owned by: jpm@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: fkr@…, ari@…
Port:

Description

The viewcvs port is not properly destrooted, referencing the workpath in its scripts.

Change History (8)

comment:1 Changed 18 years ago by jpm@…

Status: newassigned

mmm, i am a little confused what you mean by referencing the workpath. i do use the worksrcpath to reference some files for patching but i cannot find any references to the workpath itself.

can you give an example of when it breaks? thanks for pointing this out...

comment:2 Changed 18 years ago by landonf@…

Sorry, I should have attached an example to begin with.

landonf@lerkim:~> /opt/local/viewcvs/standalone.py -r foo Traceback (most recent call last):

File "/opt/local/viewcvs/standalone.py", line 511, in ?

import viewcvs

ImportError: No module named viewcvs

If you look at /opt/local/viewcvs/standalone.py: LIBRARY_DIR = "/Users/landonf/Documents/Code/OpenDarwin/darwinports/dports/devel /viewcvs/work/destroot/opt/local/viewcvs/lib"

Paths like this exist throughout the entirity of the viewcvs install. I have the same problem with my cm3 port, currently, and am trying to decide the best way to fix it over there. Hopefully viewcvs will be easier, cm3 is a beast.

comment:3 Changed 18 years ago by jpm@…

yeah this port sucks; i installed onto a mac os x server machine and finally felt the pain. i will spend some time resolving the madness this weekend.

comment:4 Changed 17 years ago by jpm@…

Cc: ari@… added

comment:5 Changed 17 years ago by jpm@…

* Bug 733 has been marked as a duplicate of this bug. *

comment:6 Changed 17 years ago by fkr@…

Cc: fkr@… added

what's the status on this? Does anyone care for this port? If not, I see no reason not to put it into the attic until someone wants it around again. -fkr

comment:7 Changed 17 years ago by bchesneau@…

mmm, didn't see this bug when I query this morning.... Problem of cache, I guess. Thx to fkr to point it. Anyway I post a patch to fix this bug. See bug #996.

comment:8 Changed 17 years ago by fkr@…

Resolution: fixed
Status: assignedclosed

this has been closed as #996 has been closed. -fkr

Note: See TracTickets for help on using tickets.