Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52720 closed defect (fixed)

abiword-x11 fails to build

Reported by: pdvnl Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: haspatch Cc: Blokkendoos (Johan), Crosmatron, kurthindenburg (Kurt Hindenburg)
Port: abiword-x11

Description

port version: Version: 2.3.4

abiword-x11 @2.8.6_4 (editors, textproc, gnome)

:error:build org.macports.build for port abiword-x11 returned: command execution failed
:debug:build Error code: CHILDSTATUS 42310 2
:debug:build Backtrace: command execution failed

Attachments (4)

main.log (210.3 KB) - added by pdvnl 4 years ago.
logfile
abiword-jpeg-patch.diff (876 bytes) - added by Crosmatron 4 years ago.
abiword patch to fix ut_jpeg.cpp
Portfile-abiword.diff (409 bytes) - added by Crosmatron 4 years ago.
Modified Portfile
main.2.log (255.0 KB) - added by pdvnl 4 years ago.
log file after apply patches

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by pdvnl

Attachment: main.log added

logfile

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Port: abiword-x11 added

In the future, please fill in the Port field.

comment:2 Changed 4 years ago by Blokkendoos (Johan)

Cc: Blokkendoos added

Changed 4 years ago by Crosmatron

Attachment: abiword-jpeg-patch.diff added

abiword patch to fix ut_jpeg.cpp

comment:3 Changed 4 years ago by Crosmatron

Cc: Crosmatron added

Changed 4 years ago by Crosmatron

Attachment: Portfile-abiword.diff added

Modified Portfile

comment:4 Changed 4 years ago by Crosmatron

All I've done is change the booleans used. It should compile more reliably now.

comment:5 Changed 4 years ago by mf2k (Frank Schima)

Keywords: haspatch added

Changed 4 years ago by pdvnl

Attachment: main.2.log added

log file after apply patches

comment:6 Changed 4 years ago by pdvnl

applied patches:

cd $(port dir abiword-x11)
sudo patch --backup -p0 < ~/Develop/abiword-x11/Portfile-abiword.diff
sudo cp -av  ~/Develop/abiword-x11/abiword-jpeg-patch.diff files
sudo port install abiword-x11

same result:

Error: org.macports.build for port abiword-x11 returned: command execution failed

comment:7 in reply to:  6 Changed 4 years ago by Crosmatron

Replying to pdvnl:

applied patches:

cd $(port dir abiword-x11)
sudo patch --backup -p0 < ~/Develop/abiword-x11/Portfile-abiword.diff
sudo cp -av  ~/Develop/abiword-x11/abiword-jpeg-patch.diff files
sudo port install abiword-x11

same result:

Error: org.macports.build for port abiword-x11 returned: command execution failed

According to your logs, abiword-jpeg-patch.diff didn't patch at all. Which is strange, because I just did the same thing and it worked fine.

It looks like you didn't do a port clean abiword-x11.

Last edited 4 years ago by Crosmatron (previous) (diff)

comment:8 Changed 4 years ago by pdvnl

you are right.

port clean abiword-x11
port install abiword-x11

now abiword-x11 is installed. thanks!

will this be fixed in the official macports?

comment:9 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: newclosed

In faca8b38/macports-ports:

abiword-x11: add patch to fix building

closes #52720

I couldn't get 2.9.4 nor 3.0.2 to build/run correctly. It will need
more work to update version. Also this should likely be combined
with abiword port.

comment:10 Changed 4 years ago by kurthindenburg (Kurt Hindenburg)

Cc: kurthindenburg added
Note: See TracTickets for help on using tickets.