Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#52730 closed enhancement (fixed)

Upgrade of apache geode port

Reported by: kjduling (Kevin Duling) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: kduling@…, dev@…
Port: geode-devel

Description

This is an update of the port for apache geode. This ticket contains a diff for the old databases/geode-devel port file, deprecating it in favor of the new databases/apache-geode port file. This upgrades Apache Geode from Milestone 2 to release 1.0.0.

Attachments (2)

geode-devel.diff (2.3 KB) - added by kjduling (Kevin Duling) 4 years ago.
Diff file to deprecate old geode-devel port
Portfile (2.1 KB) - added by kjduling (Kevin Duling) 4 years ago.
New port file for databases/apache-geode for release 1.0.0

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by kjduling (Kevin Duling)

Attachment: geode-devel.diff added

Diff file to deprecate old geode-devel port

Changed 4 years ago by kjduling (Kevin Duling)

Attachment: Portfile added

New port file for databases/apache-geode for release 1.0.0

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: dev@… added
Keywords: haspatch added
Milestone: MacPorts 2.3.5
Version: 2.3.4

Thank you.

The Milestone field is for use by Macports team members only, please do not set it.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Type: updateenhancement

comment:3 Changed 4 years ago by raimue (Rainer Müller)

Reproducing my comment I made on the related pull request:

I personally have no confidence in reviewing any Java related port. For example, I don't know if it is wise to use compiled Java class files and whether these will work on all available Java runtimes on the various versions of OS X.

comment:4 Changed 4 years ago by kjduling (Kevin Duling)

I recognize the concern and had the same reaction when I did the original port for Apache Geode M2. So, I looked at what other maintainers had done. Some Java ports install binaries while others install source and build locally. Maven and gradle are two examples of Apache apps in Java that are under MacPorts as binary installs. As the Homebrew maintainer for Geode chose to do a binary install, I went that route to maintain consistency.

Geode definitely has some requirements, as do the other Java binary ports. Geode needs Java 1.8. The version of OSX is (should be) irrelevant.

If you would rather see the port download sources and compile, the Portfile can be rewritten to do this instead. But due to the inconsistency of ports in the database, I feel that MacPorts should come up with a policy defining when a binary port is acceptable, and when it is not.

comment:5 Changed 3 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

In bdf4206c9797e0ba7882225f1a6352adf55dc631/macports-ports:

apache-geode: New port replacing geode-devel

Closes: #52730

comment:6 Changed 3 years ago by raimue (Rainer Müller)

As nobody else commented and there does not seem to be much interest in Java from other project members, I finally took the time to commit this as-is.

Thank you for your contribution. For future updates as a maintainer, just submit patches as an attachment to a new Trac ticket or make a GitHub pull request.

Note: See TracTickets for help on using tickets.