Opened 4 years ago

Closed 4 years ago

#52733 closed enhancement (fixed)

libnetdude, netdude: remove outdated ports that depend on gtk1/glib1

Reported by: dbevans (David B. Evans) Owned by: ecronin (Eric Cronin)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: removal Cc:
Port: netdude libnetdude

Description

netdude and its dependency libnetdude are some of the last ports that depend on gtk1/glib1 which were superceded by gtk2/glib2 in the early 2000's. In addition, there has been no updates for these ports since 2011 or so.

With gtk4 beta now scheduled for March 2017 it just doesn't make any sense to keep old unmaintained gnome1/gtk1 ports around.

Since these ports are blocking the current effort to remove gtk1 from MacPorts, I am asking your agreement to remove them as well. My understanding is that there are no other dependents of these ports.

Please let me know if you have any objection, that you have removed them yourself or that I have your authority as maintainer to remove these ports.

Change History (2)

comment:1 Changed 4 years ago by ecronin (Eric Cronin)

Go ahead and delete them.

comment:2 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Thanks, Eric. Deleted in r154439.

Note: See TracTickets for help on using tickets.