Opened 4 years ago

Closed 4 years ago

#52747 closed defect (duplicate)

opencv @3.1.0: fatal error: 'QTKit/QTKit.h' file not found

Reported by: mcruggs Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: lauracrews
Port: opencv

Description (last modified by neverpanic (Clemens Lang))

I am having troubles porting opencv:

From the terminal:

$ sudo port clean opencv
Password:
--->  Cleaning opencv

$ sudo port install opencv
--->  Computing dependencies for opencv
--->  Fetching archive for opencv
--->  Attempting to fetch opencv-3.1.0_3.darwin_16.x86_64.tbz2 from https://packages.macports.org/opencv
--->  Attempting to fetch opencv-3.1.0_3.darwin_16.x86_64.tbz2 from http://lil.fr.packages.macports.org/opencv
--->  Attempting to fetch opencv-3.1.0_3.darwin_16.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/opencv
--->  Fetching distfiles for opencv
--->  Verifying checksums for opencv
--->  Extracting opencv
--->  Applying patches to opencv
--->  Configuring opencv
--->  Building opencv
Error: org.macports.build for port opencv returned: command execution failed
Please see the log file for port opencv for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port opencv failed

From the Error Log

::info:build [ 59%] Built target opencv_photo
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/build'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/work/build" && /usr/bin/make -j8 -w all VERBOSE=ON 
:info:build Exit code: 2
:error:build org.macports.build for port opencv returned: command execution failed
:debug:build Error code: CHILDSTATUS 31593 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"portbuild::build_main org.macports.build"
    ("eval" body line 1)
    invoked from within
"eval $procedure $targetname"
:info:build Warning: targets not executed for opencv: org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Please see the log file for port opencv for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_opencv/opencv/main.log

Thank you for your help!

Attachments (2)

main.log.zip (22.1 KB) - added by mcruggs 4 years ago.
main.log (96.4 KB) - added by lauracrews 4 years ago.
lauracrews log

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Owner: changed from macports-tickets@… to stromnov
Status: newassigned

comment:2 Changed 4 years ago by neverpanic (Clemens Lang)

Unfortunately the relevant part is cut off. Could you attach the complete main.log?

Changed 4 years ago by mcruggs

Attachment: main.log.zip added

Changed 4 years ago by lauracrews

Attachment: main.log added

lauracrews log

comment:3 Changed 4 years ago by lauracrews

I seem to be having the same problem (log added). Any advice?

comment:4 Changed 4 years ago by ryandesign (Ryan Schmidt)

Cc: lauracrews added
Keywords: opencv removed
Port: opencv added
Resolution: duplicate
Status: assignedclosed
Summary: port opencv returned: command execution failedopencv @3.1.0: fatal error: 'QTKit/QTKit.h' file not found

Both attached logs show the same error. Duplicate of #52328.

Note: See TracTickets for help on using tickets.