Opened 2 years ago

Closed 22 months ago

#52889 closed defect (duplicate)

gdb 7.1.9 won't work on sierra 10.12.1 (and preumably on any later release)

Reported by: uliano Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc: rickyz (Ricky Zhou), plinss (Peter Linss), lks100
Port: gdb

Description

as explained here:

http://blog.adacore.com/gnat-on-macos-sierra

there is no more the possibility to disable CSR and it is not enough to to add the line 'set startup-with-shell off' in .gdbinit

however there exists a patch

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=commit;h=82b19a4d2f9c9e8d56fdffdd702f7db4af486386

for current repository version of gdb

Change History (6)

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to stuartwesterman
Status: newassigned

In the future, please Cc the port maintainers (port info --maintainers gdb), if any.

comment:2 Changed 2 years ago by rickyz (Ricky Zhou)

Cc: rickyz added

comment:3 Changed 2 years ago by plinss (Peter Linss)

Cc: plinss added

comment:4 Changed 2 years ago by lks100

Cc: lks100 added

comment:5 Changed 23 months ago by mf2k (Frank Schima)

Owner: stuartwesterman deleted

comment:6 Changed 22 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #54217 which has a patch.

Note: See TracTickets for help on using tickets.