Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52893 closed defect (fixed)

gimp @2.8.18_0 (active)

Reported by: giovannicantele Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: gimp

Description (last modified by mf2k (Frank Schima))

Operating system: macOS Sierra Version 10.12.1

MacPorts 2.3.4

Executing gimp from Terminal produces the following output message:

''objc[75409]: Class SDLTranslatorResponder is implemented in both /opt/local/lib/libSDL2-2.0.0.dylib (0x104f51e28) and /opt/local/lib/libSDL-1.2.0.dylib (0x105d11b90). One of the two will be used. Which one is undefined.''

The prompt is not returned, but nothing happens, so NO gimp window is opened. One can just exit with Ctrl-C.

Change History (16)

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Priority: HighNormal

The Priority field is for use by Macports team members only.

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Keywords: gimp libsdl libsdl2 removed
Owner: changed from macports-tickets@… to dbevans
Port: @2.8.18_0 removed
Status: newassigned

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers gimp), if any.

comment:3 Changed 4 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 4 years ago by dbevans (David B. Evans)

Status: assignedaccepted

Confirmed. As the error message indicates there appears to be a conflict between libsdl and libsdl2. Apparently only one should be active at any given time.

The problem appears to be with gegl which depends on libsdl but also depends on ffmpeg which now depends on libsdl2. Working on a fix.

comment:5 Changed 4 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: acceptedclosed

In 0161099/macports-ports:

gegl: disable optional libsdl support

Resolves linking conflict between libsdl and libsdl2 used by ffmpeg.
Fixes #52893

comment:6 Changed 4 years ago by dbevans (David B. Evans)

Please update your ports to rebuild gegl.

sudo port selfupdate
sudo port upgrade gegl

This fixes the problem for me. Note that this is a linking conflict so it's alright for both libsdl and libsdl2 to be active at the same time but only one should be linked into any given binary. No need to rebuild gimp2.

comment:7 Changed 4 years ago by giovannicantele

This actually fixes the libsdl2 versus libsdl conflict. However, the application is still broken, because both trying lunching gimp from both terminal command line and gimp-app fails with no apparent error (for example, from gimp-app, the gimp icon appears, but NO gimp window shows up). I would like also to point out that the problem is peculiar of the macports installation, because the Application downloaded (in dmg format) directly from the gimp web site, properly works. Any hint?

comment:8 in reply to:  7 Changed 4 years ago by dbevans (David B. Evans)

Replying to giovannicantele:

This actually fixes the libsdl2 versus libsdl conflict. However, the application is still broken, because both trying lunching gimp from both terminal command line and gimp-app fails with no apparent error (for example, from gimp-app, the gimp icon appears, but NO gimp window shows up). I would like also to point out that the problem is peculiar of the macports installation, because the Application downloaded (in dmg format) directly from the gimp web site, properly works. Any hint?

gimp starts up and runs correctly for me so it's possible that the problem is specific to your MacPorts installation. What exactly are the symptoms when you start gimp from the command line?

comment:9 Changed 4 years ago by giovannicantele

>> gimp

(gimp:97296): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.

Terminal does not return the prompt, NO error message is given but NO gimp starts. I must add that until few weeks ago everything was working fine!

comment:10 Changed 4 years ago by dbevans (David B. Evans)

The gimp splash screen appears while the various plugins are begin loaded and there should be text at the bottom of the this initial gimp image that lists which plugins are begin loaded. Do you see this text and if so does it hang on any specific plugin? Do you have additional plugins installed? Out of gimp2, gimp and gimp-app which are currently installed?

comment:11 Changed 4 years ago by giovannicantele

>> port installed | grep gimp
  gimp @2.8.18_0 (active)
  gimp-app @2.8.2_2 (active)
  gimp-help-en @2.8.2_0 (active)
  gimp-jp2 @2.2.0_7 (active)
  gimp-lqr-plugin @0.7.2_1 (active)
  gimp2 @2.8.18_3+python27 (active)

After I give the gimp command in Terminal, there is NO additional text displayed but the one I gave above. So no plugin starts, or at list no plugin is able for some reason to output text in terminal.

comment:12 Changed 4 years ago by dbevans (David B. Evans)

In addition to these gimp installs gutenprint ufraw and xsane. Try deactivating all these extra plugins and see if it starts any better.

sudo port -f deactivate gimp-jp2 gimp-lqr-plugin gutenprint ufraw xsane

I have to go to a meeting right now but will be back later this morning.

comment:13 Changed 4 years ago by giovannicantele

Yesterday I turned of my computer, after restart gimp works properly. Thanks a lot for all support, for all replies and for the patience you have shown!

comment:14 Changed 4 years ago by dbevans (David B. Evans)

Glad it's working for you.

comment:15 Changed 4 years ago by dbevans (David B. Evans)

In ab5fe88d/macports-ports:

gegl-0.3: disable optional libsdl support

Resolves linking conflict between libsdl and libsdl2 used by ffmpeg.
See #52893

comment:16 Changed 4 years ago by dbevans (David B. Evans)

In 2961493f/macports-ports:

gegl-devel: disable optional libsdl support

Resolves linking conflict between libsdl and libsdl2 used by ffmpeg.
See #52893

Note: See TracTickets for help on using tickets.