Opened 4 years ago

Closed 4 years ago

#52899 closed defect (duplicate)

inkscape-0.91_19+quartz+strict.darwin_15.x86_64 build failure

Reported by: McDutchie (Martijn Dekker) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.3.4
Keywords: Cc:
Port: inkscape

Description

Inkscape 0.91_19 with options +quartz +strict doesn't build for me on Mac OS X 10.11.6 with Xcode 8.1 and clang version "Apple LLVM version 8.0.0 (clang-800.0.42.1)".

The error seems to be:

:info:build /opt/local/include/glibmm-2.4/glibmm/threads.h:209:11: error: field has incomplete type 'GThread' (aka '_GThread')
:info:build   GThread gobject_;
:info:build           ^

Build log attached.

Attachments (1)

main.log.xz (29.3 KB) - added by McDutchie (Martijn Dekker) 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by McDutchie (Martijn Dekker)

Attachment: main.log.xz added

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: dbevans removed
Milestone: MacPorts 2.3.5
Owner: changed from macports-tickets@… to dbevans
Status: newassigned

The Milestone field is for use by Macports team members only, please do not set it.

comment:2 Changed 4 years ago by dbevans (David B. Evans)

Resolution: duplicate
Status: assignedclosed

Duplicate of #52248. Please build without the +strict variant.

Note: See TracTickets for help on using tickets.