Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#52913 closed defect (fixed)

qt5 @5.6.2_0: please re-enable builds on 10.7

Reported by: mojca (Mojca Miklavec) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: lion Cc: mkae (Marko Käning), iEFdev
Port: qt5

Description

Commit d1509f4a/macports-ports disabled building Qt 5.6 on 10.7 even though it seems to build without any major problems and the packages from the buildbot confirm that (5.6.1 is there for darwin11).

Can we please reenable support for OS X 10.7 (for version 5.6).

See also #51801.

Change History (5)

comment:1 Changed 4 years ago by iEFdev

Cc: iEFdev added

comment:2 Changed 4 years ago by mojca (Mojca Miklavec)

The only problem I found so far comes from building qt5-qtmultimedia:

:info:build avfcamerautility.mm:549:92: error: property 'firstObject' not found on object of type 'NSArray *'
:info:build         AVFrameRateRange *range = captureDevice.activeFormat.videoSupportedFrameRateRanges.firstObject;
:info:build                                                                                            ^
:info:build 1 error generated.

comment:3 Changed 4 years ago by mojca (Mojca Miklavec)

According to https://developer.apple.com/reference/avfoundation/avcapturedeviceformat/1387592-videosupportedframerateranges the function videoSupportedFrameRateRanges is 10.10+, so I'm confused.

In any case, all other qt5 modules (that I installed earlier) compiled successfully.

comment:4 Changed 4 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: fixed
Status: newclosed

In 742c8676/macports-ports:

qt5 PortGroup: allow installation attempt on
unsupported platforms, with a warning

Even though Qt 5.6 is not supported on Mac OS X 10.7, there has been
some success in building it.
Allow the installation attempt at least until there is consensus that
Qt will not work.

Fixes #52913

comment:5 Changed 4 years ago by mojca (Mojca Miklavec)

Thank you. Here's a link to the build on 10.7. See #52922.

Last edited 4 years ago by mojca (Mojca Miklavec) (previous) (diff)
Note: See TracTickets for help on using tickets.