Opened 2 years ago

Closed 10 months ago

#52978 closed defect (invalid)

qt5 applications not finding platforms plugins

Reported by: dmarteau (David Marteau) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.3.5
Keywords: Cc: mkae (Marko Käning)
Port: qt5

Description (last modified by mf2k (Frank Schima))

Actually when compiling and running a qt5 application I need to set up explicitly the environnement variable QT_QPA_PLATFORM_PLUGIN_PATH or the application would not start with the error:

Fatal: This application failed to start because it could not find or load the Qt platform plugin "cocoa"
in "".

It is not clear if this is a qt5 installation problem or if this should be handled by the application.

Thanks

Change History (9)

comment:1 Changed 2 years ago by mkae (Marko Käning)

Cc: mkae added

comment:2 Changed 2 years ago by mf2k (Frank Schima)

Owner: set to MarcusCalhoun-Lopez
Status: newassigned
Type: enhancementdefect

In the future, please use WikiFormatting and Cc the port maintainers (port info --maintainers qt5), if any.

comment:3 Changed 2 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:4 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

It would help if I could reproduce this error.
What application is failing?
Is it a MacPorts application?

comment:5 Changed 2 years ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Status: assignedaccepted

comment:6 Changed 2 years ago by dmarteau (David Marteau)

No this is not a MacPorts application, this in QGIS (from branch master) which now depends on QT5 that I am compiling.

All compiling tools (cmake) and qt5 libraries are from Macports installation.

This is why I said that it is not clear for me if this is a qt5 installation problem or if this should be handled by the application at compile time.

Afaik this problem does not occurs on linux platform.

comment:7 Changed 2 years ago by dmarteau (David Marteau)

Did you get some clue about this ?

comment:8 Changed 11 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

I am sorry, but I do not know how to proceed from here.
If I can not reproduce the error, it is very difficult to fix.
By any chance, has some subsequent Qt updated fixed the problem?

comment:9 Changed 10 months ago by MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)

Resolution: invalid
Status: acceptedclosed

Closing since is it very difficult to debug a non-MacPorts application.
Sorry I could not be more help.

Note: See TracTickets for help on using tickets.