Opened 15 years ago

Closed 15 years ago

#5299 closed defect (fixed)

BUG: py-gtk2 doesn't build

Reported by: olaf@… Owned by: yves@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

$ sudo port install py-gtk2 ---> Fetching py-gtk2 ---> Verifying checksum(s) for py-gtk2 ---> Extracting py-gtk2 ---> Configuring py-gtk2 ---> Building py-gtk2 with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_python_py-gtk2/work/pygtk-2.8.0" && make all" returned error 2 Command output: /opt/local/include/gtk-2.0/gdk/gdkx.h:64: warning: type defaults to int' in declaration of gdk_x11_get_default_xdisplay' /opt/local/include/gtk-2.0/gdk/gdkx.h:64: warning: data definition has no type or storage class /opt/local/include/gtk-2.0/gdk/gdkx.h:126: error: parse error before "VisualID" /opt/local/include/gtk-2.0/gdk/gdkx.h:128: error: parse error before "xvisualid" /opt/local/include/gtk-2.0/gdk/gdkx.h:137: error: parse error before "Colormap" /opt/local/include/gtk-2.0/gdk/gdkx.h:141: error: parse error before "XID" /opt/local/include/gtk-2.0/gdk/gdkx.h:154: error: parse error before "xid" /opt/local/include/gtk-2.0/gdk/gdkx.h:160: error: parse error before '*' token /opt/local/include/gtk-2.0/gdk/gdkx.h:164: error: parse error before "gdk_x11_atom_to_xatom_for_display" /opt/local/include/gtk-2.0/gdk/gdkx.h:165: warning: type defaults to `int' in declaration of `gdk_x11_atom_to_xatom_for_display' /opt/local/include/gtk-2.0/gdk/gdkx.h:165: warning: data definition has no type or storage class /opt/local/include/gtk-2.0/gdk/gdkx.h:167: error: parse error before "Atom" /opt/local/include/gtk-2.0/gdk/gdkx.h:168: error: parse error before "gdk_x11_get_xatom_by_name_for_display" /opt/local/include/gtk-2.0/gdk/gdkx.h:169: warning: type defaults to `int' in declaration of `gdk_x11_get_xatom_by_name_for_display' /opt/local/include/gtk-2.0/gdk/gdkx.h:169: warning: data definition has no type or storage class /opt/local/include/gtk-2.0/gdk/gdkx.h:171: error: parse error before "Atom" /opt/local/include/gtk-2.0/gdk/gdkx.h:173: error: parse error before "gdk_x11_atom_to_xatom" /opt/local/include/gtk-2.0/gdk/gdkx.h:173: warning: type defaults to `int' in declaration of `gdk_x11_atom_to_xatom' /opt/local/include/gtk-2.0/gdk/gdkx.h:173: warning: data definition has no type or storage class /opt/local/include/gtk-2.0/gdk/gdkx.h:174: error: parse error before "xatom" /opt/local/include/gtk-2.0/gdk/gdkx.h:175: error: parse error before "gdk_x11_get_xatom_by_name" /opt/local/include/gtk-2.0/gdk/gdkx.h:175: warning: type defaults to `int' in declaration of `gdk_x11_get_xatom_by_name' /opt/local/include/gtk-2.0/gdk/gdkx.h:175: warning: data definition has no type or storage class /opt/local/include/gtk-2.0/gdk/gdkx.h:176: error: parse error before "xatom" /opt/local/include/gtk-2.0/gdk/gdkx.h:196: error: parse error before '*' token /opt/local/include/gtk-2.0/gdk/gdkx.h:196: warning: type defaults to `int' in declaration of `gdk_x11_font_get_xdisplay' /opt/local/include/gtk-2.0/gdk/gdkx.h:196: warning: data definition has no type or storage class make[2]: * [_gtk_la-gdk.lo] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

$ port installed gtk2 The following ports are currently installed:

gtk2 2.8.4_0 (active)

Attachments (1)

build.log (79.8 KB) - added by olaf@… 15 years ago.
output of port -d build

Download all attachments as: .zip

Change History (9)

comment:1 Changed 15 years ago by yves@…

Status: newassigned

Hi

I just updated py-gtk2 to version 2.8.1 so you can try it soon

However, I don't think that will help. It looks like a compiler issue and I really don't have the time to look at this right now because of "The Real World (TM)" -- sorry

If it fails again, please include the output of "port -d build"

thanks

comment:2 Changed 15 years ago by olaf@…

(In reply to comment #1)

Hi

I just updated py-gtk2 to version 2.8.1 so you can try it soon

However, I don't think that will help. It looks like a compiler issue and I

really don't have the time to look

at this right now because of "The Real World (TM)" -- sorry

If it fails again, please include the output of "port -d build"

thanks

You're right it doesn't build either. Log is attached.

I'm on vacation now for a week so don't worry.

Regards Olaf

Changed 15 years ago by olaf@…

Attachment: build.log added

output of port -d build

comment:3 Changed 15 years ago by mww@…

Summary: py-gtk2 doesn't buildBUG: py-gtk2 doesn't build

comment:4 Changed 15 years ago by yves@…

Please verify you have these two files :

/usr/X11R6/include/X11/Xlib.h /usr/X11R6/include/X11/Xutil.h

if you do have them, I'll have a fix very soon. If you don't then you probably did something very brave with your system ;-)

comment:5 Changed 15 years ago by olaf@…

(In reply to comment #4)

Please verify you have these two files :

/usr/X11R6/include/X11/Xlib.h /usr/X11R6/include/X11/Xutil.h

if you do have them, I'll have a fix very soon. If you don't then you

probably did something very brave

with your system ;-)

$ ls /usr/X11R6/include/X11/Xlib.h /usr/X11R6/include/X11/Xlib.h $ ls /usr/X11R6/include/X11/Xutil.h /usr/X11R6/include/X11/Xutil.h

all is fine. I'm eagerly waiting for the fix.

comment:6 Changed 15 years ago by yves@…

Fix is in cvs, should be available soon

comment:7 Changed 15 years ago by olaf@…

(In reply to comment #6)

Fix is in cvs, should be available soon

Fix is fine it should be

platform darwin 7 {

configure.env CFLAGS="-I${x11prefix}/include"

}

comment:8 Changed 15 years ago by yves@…

Resolution: fixed
Status: assignedclosed

Thanks for noticing this omission.

Note: See TracTickets for help on using tickets.