Opened 12 months ago

Last modified 12 months ago

#53204 assigned defect

Error: Processing of port netcdf-fortran failed

Reported by: jmbeuken (Jean-Michel Beuken) Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.3.5
Keywords: elcapitan Cc:
Port: netcdf-fortran

Description

Try to install last version ( 4.4.4 ) of "netcdf-fortran +gcc49" on El capitan

Xcode 8.2.1 ( Build version 8C1002 )

before, it works with :

netcdf @4.4.0_3+dap+gcc49+netcdf4 (active)
netcdf-fortran @4.4.3_0+gcc49 (active)

tail of "netcdf-fortran/main.log" :

/opt/local/bin/gfortran-mp-4.9 -DHAVE_CONFIG_H -I. -I.. -I../libsrc   -I/opt/local/include -DNDEBUG -DpgiFortran  -pipe -Os -c -o module_netcdf_nf_interfaces.o module_netcdf_nf_interfaces.F90

:info:build Fatal Error: Reading module netcdf_nf_data at line 1754 column 46: Unexpected EOF

List of commands :

sudo port -fp uninstall installed
<snip>

sudo port installed
No ports are installed.

sudo port install netcdf-fortran +gcc49

--->  Computing dependencies for netcdf-fortran
--->  Dependencies to be installed: gcc49 cctools llvm-3.9 libcxx libedit ncurses libffi llvm_select xar bzip2 libiconv libxml2 xz gettext expat zlib openssl cloog gmp isl gcc_select ld64 ld64-latest libgcc libmpc mpfr netcdf cmake curl curl-ca-bundle libarchive lzo2 libuv hdf5-18

<snip>

--->  Activating netcdf @4.4.1_2+dap+gcc49+netcdf4

<snip>

--->  Cleaning netcdf
--->  Building netcdf-fortran
Error: org.macports.build for port netcdf-fortran returned: command execution failed
Please see the log file for port netcdf-fortran for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_netcdf-fortran/netcdf-fortran/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port netcdf-fortran failed

Change History (4)

comment:1 Changed 12 months ago by jmbeuken (Jean-Michel Beuken)

  • Cc jmbeuken added

comment:2 follow-up: Changed 12 months ago by ryandesign (Ryan Schmidt)

It might not be related to the problem you're seeing, but is there any particular reason why you want to use the old gcc49? The latest stable version of gcc is gcc6.

comment:3 Changed 12 months ago by ryandesign (Ryan Schmidt)

  • Cc takeshi@… jmbeuken removed
  • Owner set to tenomoto
  • Port 4.4.4 removed
  • Status changed from new to assigned

comment:4 in reply to: ↑ 2 Changed 12 months ago by jmbeuken (Jean-Michel Beuken)

Replying to ryandesign:

It might not be related to the problem you're seeing, but is there any particular reason why you want to use the old gcc49? The latest stable version of gcc is gcc6.

It's historical ! We have a test farm for testing ABINIT code and this MacOS X bot tested MacPorts packages : gcc4.9+atlas+netcdf+scalapack+wannier90+openmpi under buildbot framework (buildbot-slave port ) with autotools/autoconf tools

I try with gcc6 and it works :-)

I talk about it with the developer team if we will update the gcc version... we have already an other bot with gcc 6.1/CentOS 7

Note: See TracTickets for help on using tickets.