Opened 4 years ago

Closed 3 years ago

#53307 closed update (fixed)

Update libvpx to v1.6.1

Reported by: johannkoenig (wwcv) Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: libvpx

Description

libvpx has released a new version: https://groups.google.com/a/webmproject.org/d/msg/codec-devel/Vt6c2Z96cWI/aTYeP5y6BwAJ

https://chromium.googlesource.com/webm/libvpx/+archive/v1.6.1.tar.gz

Although PPC support was removed in v1.5.0, using --target=generic-gnu a C-only build can be created. Since versions before v1.5.0 didn't have any optimizations for PPC, it wouldn't represent a performance regression. I don't know how useful that library would be to people though.

The configure script in macports was massively simplified for the last update: https://github.com/macports/macports-ports/blob/master/multimedia/libvpx/files/patch-build-make-configure.sh.diff

Are the -mmacosx-version-min/max flags no longer useful? We'd be happy to take that patch upstream if that is the case.

The port warns against support for 10.5: https://github.com/macports/macports-ports/commit/026309f6708aa8ea7846b44b450c1484dac9e0ed#diff-37bbebaa31f457b80e2845b095b284bd

Is this because of an outdated compiler? Otherwise I'm not aware of any reason the library would not run on 10.5. Similar to PPC, --target=generic-gnu could provide a workaround but it would still be very slow.

Change History (6)

comment:1 Changed 4 years ago by jmroot (Joshua Root)

Cc: dbevans removed
Owner: set to dbevans
Port: libvpx added
Status: newassigned

comment:2 Changed 4 years ago by dbevans (David B. Evans)

Status: assignedaccepted

Thanks for the heads up on this release. I see the release tag in upstream git master and can download the snapshot but the port's livecheck rules which check for new releases miss this because the release has not been indexed in

http://downloads.webmproject.org/releases/webm/index.html

per the WebM guidelines

http://www.webmproject.org/code/releases/

The prohibition against building on 10.5 and earlier is due to the fact that builds on those platforms, in general, are problematic due to the outdated toolchains available there. So much so that newer versions of the respective compilers, libraries, etc either are not buildable or generate invalid PPC code on those platforms. In addition, my understanding of your updated configuration scripts was that those platforms were explicitly not supported from 1.5.0 on.

Will update to the latest version and test to see if anything has changed in this reqard. As you say, the utility of a "vanilla" PPC build of this package may be limited by performance issues.

I appreciate your input and will let you know what works and what doesn't with the new version.

comment:3 Changed 4 years ago by johannkoenig (wwcv)

Thanks for looking into it. I forgot that index.html needs to be manually updated. It should be correct now.

comment:4 Changed 4 years ago by dbevans (David B. Evans)

livecheck is working now, thanks.

DEBUG: Executing org.macports.livecheck (libvpx)
DEBUG: Port (livecheck) version is 1.6.1
DEBUG: Fetching http://downloads.webmproject.org/releases/webm/index.html
DEBUG: The regex is "libvpx-(\d+(?:\.\d+)*).tar.bz2"
DEBUG: The regex matched "libvpx-1.3.0.tar.bz2", extracted "1.3.0"
DEBUG: The regex matched "libvpx-1.4.0.tar.bz2", extracted "1.4.0"
DEBUG: The regex matched "libvpx-1.4.0.tar.bz2", extracted "1.4.0"
DEBUG: The regex matched "libvpx-1.5.0.tar.bz2", extracted "1.5.0"
DEBUG: The regex matched "libvpx-1.5.0.tar.bz2", extracted "1.5.0"
DEBUG: The regex matched "libvpx-1.6.0.tar.bz2", extracted "1.6.0"
DEBUG: The regex matched "libvpx-1.6.0.tar.bz2", extracted "1.6.0"
DEBUG: The regex matched "libvpx-1.6.1.tar.bz2", extracted "1.6.1"
DEBUG: The regex matched "libvpx-1.6.1.tar.bz2", extracted "1.6.1"
libvpx seems to be up to date

Will test 1.6.1 on Leopard and Tiger PPC tonight using a generic build as you suggest.

comment:5 Changed 4 years ago by dbevans (David B. Evans)

In efe2374/macports-ports:

libvpx: update to version 1.6.1

  • generic build for 10.5 and earlier under investigation

See: #53307

comment:6 Changed 3 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.