Opened 4 years ago

Closed 4 years ago

#53409 closed defect (duplicate)

python36 crashes with malloc error

Reported by: jsalort (Julien Salort) Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 2.4.0
Keywords: Cc:
Port: python36

Description

I am running python36 on Sierra with MacPorts 2.4.0.

% port installed python36
The following ports are currently installed:
  python36 @3.6.0_0 (active)
% port version
Version: 2.4.0

It crashes when I start the REPL:

% python3.6
Python 3.6.0 (default, Dec 23 2016, 12:50:55) 
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.38)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> a=2
Python(26362,0x7fffab1043c0) malloc: *** error for object 0x108253640: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

The same code snippet works without the REPL:

% python3.6 -c "a=2; print(a)"
2

No python36 package is installed apart py36-readline.

The other installed python versions are perfectly working.

% port installed "python*"
The following ports are currently installed:
  python-mode.el @1.0_0 (active)
  python2_select @0.0_2 (active)
  python3_select @0.0_1 (active)
  python27 @2.7.12_2
  python27 @2.7.13_0 (active)
  python34 @3.4.5_1
  python34 @3.4.5_2
  python34 @3.4.6_0 (active)
  python35 @3.5.2_1
  python35 @3.5.2_2
  python35 @3.5.3_0 (active)
  python36 @3.6.0_0 (active)
  python_select @0.3_7 (active)

Change History (2)

comment:1 Changed 4 years ago by mf2k (Frank Schima)

Cc: jyrkiwahlstedt removed
Owner: set to jyrkiwahlstedt
Status: newassigned

comment:2 Changed 4 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #53360.

Note: See TracTickets for help on using tickets.